CVE-2026-63924·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: ipv6: exthdrs: refresh nh pointer after ipv6_hop_jumbo() ipv6_hop_jumbo() calls pskb_trim_rcsum(), which can change skb pointers. Let's recompute nh pointer to make sure any change won't mess things up.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 7.0.12
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.71% — higher than 53% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-63924 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.71%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 6.19
Until: 7.0.12
Fixed in: 7.0.12
How to fix this CVE
Update your Linux kernel to version 7.0.12 or later to patch a critical memory handling vulnerability in IPv6 extension header processing. This vulnerability affects kernel versions 6.19 through 7.0.11 and can be exploited remotely without authentication. Apply the patch immediately as it resolves a pointer invalidation issue that occurs during jumbo payload processing.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Step 1: Run 'uname -r' to display the currently running kernel version and verify if it falls within the vulnerable range (6.19 to 7.0.11)
- Step 2: Check if IPv6 is enabled on your system with 'cat /proc/sys/net/ipv6/conf/all/disable_ipv6' (0 = enabled, 1 = disabled); if 0, the system is potentially vulnerable
- Step 3: Search kernel logs for IPv6 extension header processing errors using 'sudo dmesg | grep -i "ipv6\|exthdrs\|jumbo"' to detect any anomalous packet handling
- Step 4: After patching, run 'uname -r' again and verify the kernel version is 7.0.12 or later, then confirm with 'sudo systemctl reboot' if a kernel upgrade was installed
FAQ
What is CVE-2026-63924?
A critical memory safety vulnerability in the Linux kernel's IPv6 extension header processing where the network header pointer becomes invalid after jumbo payload handling, potentially leading to out-of-bounds memory access and system compromise.
Is CVE-2026-63924 being actively exploited?
No, there is currently no evidence of active exploitation in the wild, and no public proof-of-concept exploits are available, but the CVSS 9.8 severity rating warrants immediate patching.
What versions of Kernel are affected by CVE-2026-63924?
Linux kernel versions 6.19 through 7.0.11 are vulnerable; version 7.0.12 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-63924?
Run 'uname -r' to check your kernel version—if it shows a version between 6.19 and 7.0.11 and IPv6 is enabled (check with 'cat /proc/sys/net/ipv6/conf/all/disable_ipv6'), your system is vulnerable.
Does Defensia detect CVE-2026-63924?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the Linux kernel is installed on a monitored server, CVE-2026-63924 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/2b56bbd928c030894c270cd33d60286326919458
- https://git.kernel.org/stable/c/645b99b1a185c91a79bdac4c5de0f91b212d64f0
- https://git.kernel.org/stable/c/72af7beae774e46ed543f3f2f267bf0a141bfcdd
- https://git.kernel.org/stable/c/9e883eaa878f4337b5873c706efb5a192364ed18
- https://git.kernel.org/stable/c/b3ac54e5c905f86d22b502eacb5686a282c5659f
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63924. Free for 1 server.
Get started free