CVE-2026-63912·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: xfrm: esp: restore combined single-frag length gate The ESP out-of-place fast path appends the trailer in esp_output_head() before esp_output_tail() allocates the destination page frag. The head-side gate currently checks skb->data_len and tailen separately, but the tail code allocates a single destination frag from the combined post-trailer skb->data_len. Reject the page-frag fast path when the combined aligned length exceeds a page. Otherwise skb_page_frag_refill() may fall back to a single page while the destination sg still spans the combined skb->data_len. Restore this combined-length page gate for both IPv4 and IPv6.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 7.0.12
- Published
Affected versions
From: 6.19
Until: 7.0.12
Fixed in: 7.0.12
How to fix this CVE
Update your Linux kernel to version 7.0.12 or later to resolve this critical IPsec ESP encryption vulnerability. The vulnerability affects the out-of-place fast path used during IPsec packet processing, where improper memory allocation checks could lead to buffer overflows. Affected systems running kernel versions 6.19 through 7.0.11 should prioritize this update, especially if they use IPsec for VPN or site-to-site encryption.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Check your current kernel version: uname -r — compare against the fixed version (7.0.12 or later)
- Verify IPsec/xfrm functionality is enabled: grep -i 'CONFIG_XFRM\|CONFIG_INET_ESP' /boot/config-$(uname -r) — if set to 'y', the vulnerable code path is compiled
- Monitor kernel logs for xfrm or ESP-related errors: sudo journalctl -xe | grep -i 'xfrm\|esp\|skb_page_frag' — look for allocation failures or buffer-related warnings
- After patching, confirm the new kernel is running: uname -r should show 7.0.12 or later; verify with: cat /proc/version
FAQ
What is CVE-2026-63912?
CVE-2026-63912 is a memory allocation vulnerability in the Linux kernel's IPsec ESP (Encapsulating Security Payload) module that occurs when the combined trailer length exceeds page boundaries during packet encryption. This can lead to buffer overflows and kernel memory corruption.
Is CVE-2026-63912 being actively exploited?
No, CVE-2026-63912 is not currently being actively exploited in the wild according to CISA's Known Exploited Vulnerabilities catalog, and no public exploits are available.
What versions of Kernel are affected by CVE-2026-63912?
Linux kernel versions 6.19 through 7.0.11 are affected. Version 7.0.12 and later include the fix.
How do I check if my server is vulnerable to CVE-2026-63912?
Run `uname -r` and compare the output against 7.0.12. If your version is between 6.19 and 7.0.11, you are vulnerable. Additionally, verify IPsec is compiled in: `grep CONFIG_INET_ESP /boot/config-$(uname -r)`.
Does Defensia detect CVE-2026-63912?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-63912 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/322e48187e0245ab2fff6fec2220b0cae677dbec
- https://git.kernel.org/stable/c/36519e3d941fc99d3b52c134dbaf311f987a4708
- https://git.kernel.org/stable/c/566295735530ee513326049b0540f32ec050bf2e
- https://git.kernel.org/stable/c/5d7ab86e2b6bc23054616bf6ac562013bf60af8c
- https://git.kernel.org/stable/c/65f3b3fc2347b89fe21db1e92c7681368415f095
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63912. Free for 1 server.
Get started free