CVE-2026-63886·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: scsi: target: iscsi: Validate CHAP_R length before base64 decode chap_server_compute_hash() allocates client_digest as kzalloc(chap->digest_size) and then, for BASE64-encoded responses, passes chap_r directly to chap_base64_decode() without checking whether the input length could produce more than digest_size bytes of output. chap_base64_decode() writes to the destination unconditionally as long as there is input to consume. With MAX_RESPONSE_LENGTH set to 128 and the "0b" prefix stripped by extract_param(), up to 127 base64 characters can reach the decoder. 127 characters decode to 95 bytes. For SHA-256 (digest_size=32) this overflows client_digest by 63 bytes; for MD5 (digest_size=16) the overflow is 79 bytes. The length check at line 344 fires after the write has already happened. The HEX branch in the same switch statement already validates the length up front. Apply the same approach to the BASE64 branch: strip trailing base64 padding characters, then reject any input whose data length exceeds DIV_ROUND_UP(digest_size * 4, 3) before calling the decoder. Stripping trailing '=' before the comparison handles both padded and unpadded encodings. chap_base64_decode() already returns early on '=', so the full original string is still passed to the decoder unchanged. The mutual CHAP path decodes CHAP_C into initiatorchg_binhex, which is kzalloc(CHAP_CHALLENGE_STR_LEN). extract_param() caps initiatorchg at CHAP_CHALLENGE_STR_LEN characters, so at most CHAP_CHALLENGE_STR_LEN-1 base64 characters reach the decoder. The maximum decoded size, DIV_ROUND_UP((CHAP_CHALLENGE_STR_LEN-1) * 3, 4), is less than CHAP_CHALLENGE_STR_LEN, so no overflow is possible there. A comment is added at the call site to document this.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 7.0.12
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.71% — higher than 53% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-63886 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.71%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 6.19
Until: 7.0.12
Fixed in: 7.0.12
How to fix this CVE
Update the Linux kernel to version 7.0.12 or later to patch a critical buffer overflow in the iSCSI CHAP authentication handler. This vulnerability allows unauthenticated remote attackers to trigger memory corruption through malformed BASE64-encoded CHAP responses. Apply the kernel update immediately followed by a system reboot to ensure the patched kernel is running.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check the running kernel version with `uname -r` and compare against affected range 6.19 to 7.0.11.
- Step 2: Verify iSCSI target services are enabled by running `systemctl status target` or checking `/proc/net/iet_volume` for active iSCSI sessions.
- Step 3: Search system logs for CHAP authentication failures using `grep -i 'chap\|iscsi' /var/log/syslog /var/log/kern.log | grep -i 'error\|fail' | tail -100`.
- Step 4: After patching, confirm the new kernel is booted with `uname -r` and verify it shows version 7.0.12 or later.
FAQ
What is CVE-2026-63886?
A critical buffer overflow in the Linux kernel's iSCSI CHAP authentication mechanism where insufficient validation of BASE64-encoded challenge responses allows writing beyond allocated buffer boundaries, enabling unauthenticated remote code execution.
Is CVE-2026-63886 being actively exploited?
No active exploitation has been reported by CISA or security researchers at this time, and no public exploits are available. However, the critical CVSS score and remote nature of the vulnerability warrant immediate patching.
What versions of Kernel are affected by CVE-2026-63886?
Linux kernel versions 6.19 through 7.0.11 are vulnerable. Kernel 7.0.12 and later versions contain the fix.
How do I check if my server is vulnerable to CVE-2026-63886?
Run `uname -r` to get your kernel version; if it falls between 6.19 and 7.0.11, your system is vulnerable. Additionally, check if iSCSI target services are running with `systemctl status target`.
Does Defensia detect CVE-2026-63886?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the Linux kernel is installed on a monitored server, CVE-2026-63886 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/4a3a19c98a8207ad08bec554703d90f2c34a8cc6
- https://git.kernel.org/stable/c/82454e6f21e56ea9a0a9de7d0ff7e1dfb83e34d6
- https://git.kernel.org/stable/c/85db7391310b1304d2dc8ae3b0b12105a9567147
- https://git.kernel.org/stable/c/bf154c657828ed05399bca5d98cf1611bb048b12
- https://git.kernel.org/stable/c/c04e85799356120209b351a148ac2db888d5ffd9
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63886. Free for 1 server.
Get started free