high CVSS 7.5 EPSS 0.32%

CVE-2026-63718·Apache vulnerability

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') response smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi and a crafted uwsgi response with Transfer-Encoding. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.68.

Severity
high
Software
Apache
Fixed in
2.4.69
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.32% — higher than 23% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-63718 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.32%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.30

Until: 2.4.69

Fixed in: 2.4.69

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.69 or later to patch the HTTP response smuggling vulnerability in mod_proxy_uwsgi. This vulnerability allows attackers to manipulate Transfer-Encoding headers in uwsgi responses, potentially bypassing security controls and cache poisoning attacks. Ensure mod_proxy_uwsgi is disabled if not required, and test the upgrade in a staging environment before production deployment.

sudo dnf update httpd httpd-devel httpd-tools httpd-modules-*

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET|HEAD /[^ ]* HTTP/1\.1.*Transfer-Encoding:\s*(chunked|gzip|compress|deflate|identity|trailers|\s*,).*\r\n\r\n

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Configure WAF rules to detect and block HTTP responses with conflicting or ambiguous Transfer-Encoding and Content-Length headers from backend servers. Implement strict parsing rules that reject responses where Transfer-Encoding headers are present alongside Content-Length, or flag responses with multiple Transfer-Encoding directives.

How to check if you are affected

  1. Check installed Apache version: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS)
  2. Verify mod_proxy_uwsgi is loaded: apache2ctl -M | grep uwsgi (Ubuntu/Debian) or httpctl -M | grep uwsgi (RHEL/CentOS)
  3. Search Apache access logs for suspicious Transfer-Encoding headers in backend responses: grep -i 'transfer-encoding' /var/log/apache2/access.log
  4. Confirm upgrade completion by running: apache2ctl -v or httpd -v and verify version shows 2.4.69 or higher

FAQ

What is CVE-2026-63718?

This is an HTTP response smuggling vulnerability in Apache HTTP Server's mod_proxy_uwsgi module that allows attackers to craft malicious uwsgi backend responses with manipulated Transfer-Encoding headers. This can lead to cache poisoning, security filter bypass, or credential interception on proxied connections.

Is CVE-2026-63718 being actively exploited?

According to CISA's Known Exploited Vulnerabilities (KEV) catalog, CVE-2026-63718 is not currently listed as actively exploited in the wild, and no public exploit code is available.

What versions of Apache are affected by CVE-2026-63718?

Apache HTTP Server versions 2.4.30 through 2.4.68 are affected. Version 2.4.69 and later include the security patch.

How do I check if my server is vulnerable to CVE-2026-63718?

Run 'apache2ctl -v' or 'httpd -v' to display your Apache version. If it shows 2.4.30 through 2.4.68 and mod_proxy_uwsgi is enabled (check with 'apache2ctl -M | grep uwsgi'), your server requires immediate patching.

Does Defensia detect CVE-2026-63718?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-63718 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63718. Free for 1 server.

Get started free