critical CVSS 10 EPSS 0.75%

CVE-2026-44631·Apache vulnerability

Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Severity
critical
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.75% — higher than 54% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-44631 scores 10 on CVSS, so a successful attack would be serious — but at 0.75%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Apache HTTP Server versions 2.4.0 through 2.4.67 contain a buffer underwrite vulnerability triggered by specially crafted regular expressions in configuration files. Immediately upgrade to version 2.4.68-1~deb12u1 or later to patch this critical flaw. Restrict access to Apache configuration files and validate any regex patterns used in mod_rewrite or similar modules before deployment.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Run `apache2 -v` or `httpd -v` to check the installed Apache version and confirm if it falls within 2.4.0-2.4.67
  2. Step 2: Execute `apache2ctl -S` to parse and display active configuration, then review all regular expression directives in `/etc/apache2/sites-enabled/` and `/etc/apache2/mods-enabled/` for suspicious or malformed patterns
  3. Step 3: Search Apache error and access logs for segmentation faults or abnormal terminations using `grep -i 'segmentation\|core dump\|buffer' /var/log/apache2/error.log*`
  4. Step 4: After upgrading, verify the patched version with `apache2 -v` and restart the service using `sudo systemctl restart apache2`, then check service status with `sudo systemctl status apache2`

FAQ

What is CVE-2026-44631?

CVE-2026-44631 is a buffer underwrite vulnerability in Apache HTTP Server that can be triggered through maliciously crafted regular expressions in configuration directives. This memory corruption issue allows attackers to crash the server or potentially execute arbitrary code with the privileges of the Apache process.

Is CVE-2026-44631 being actively exploited?

No, CVE-2026-44631 is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available. However, the critical CVSS 10.0 score warrants immediate patching due to the severity of the vulnerability.

What versions of Apache are affected by CVE-2026-44631?

Apache HTTP Server versions 2.4.0 through 2.4.67 are vulnerable. Version 2.4.68 and later contain the fix for this buffer underwrite issue.

How do I check if my server is vulnerable to CVE-2026-44631?

Run `apache2 -v` or `httpd -v` and compare your version against the vulnerable range (2.4.0-2.4.67). If your version falls within this range, your server requires immediate patching.

Does Defensia detect CVE-2026-44631?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-44631 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-56154CVSS 9.8Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44631. Free for 1 server.

Get started free