critical CVSS 10 EPSS 0.69%

CVE-2026-29167·Apache vulnerability

Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Severity
critical
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.69% — higher than 52% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-29167 scores 10 on CVSS, so a successful attack would be serious — but at 0.69%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Apache HTTP Server versions 2.4.0 through 2.4.67 contain a use-after-free vulnerability in the mod_ldap module when processing per-directory LDAP configurations, which could allow remote code execution. Immediately upgrade to Apache 2.4.68 or later to eliminate this critical memory safety issue. Verify the patch has been applied and restart the Apache service to ensure the vulnerable code is no longer in memory.

sudo dnf update httpd && sudo systemctl restart httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'apache2 -v' or 'httpd -v' to display the currently installed Apache version and compare against 2.4.68
  2. Check if mod_ldap is enabled by running 'apache2ctl -M | grep ldap' (or 'httpd -M | grep ldap' on RHEL/CentOS); if loaded, the module is active
  3. Search Apache error logs for segmentation faults or memory-related crashes using: 'grep -i "segfault\|memory\|core dumped" /var/log/apache2/error.log'
  4. Verify the patch by confirming 'apache2 -v' shows 2.4.68 or higher, then check mod_ldap module timestamp hasn't changed since restart

FAQ

What is CVE-2026-29167?

This is a use-after-free memory corruption flaw in Apache's mod_ldap component that occurs when per-directory LDAP authentication directives are configured. An unauthenticated remote attacker can trigger the vulnerability to crash the server or execute arbitrary code with Apache's privileges.

Is CVE-2026-29167 being actively exploited?

No, there is no evidence of active exploitation in the wild as of the current advisory date, and no public exploit code has been released. However, the critical CVSS 10.0 score and ease of exploitation over the network warrant immediate patching.

What versions of Apache are affected by CVE-2026-29167?

Apache HTTP Server versions 2.4.0 through 2.4.67 are vulnerable. Version 2.4.68 and all subsequent releases contain the fix.

How do I check if my server is vulnerable to CVE-2026-29167?

Run 'apache2 -v' or 'httpd -v' and verify the version is below 2.4.68. Additionally, confirm mod_ldap is loaded with 'apache2ctl -M | grep ldap'; if this returns no output, mod_ldap is not active and the vulnerability cannot be exploited.

Does Defensia detect CVE-2026-29167?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-29167 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-56154CVSS 9.8Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-29167. Free for 1 server.

Get started free