high CVSS 7.5 EPSS 0.48%

CVE-2026-63686·Apache vulnerability

A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxied response with a charset whose conversion partially succeeds then fails. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.69
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.48% — higher than 40% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-63686 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.48%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.69

Fixed in: 2.4.69

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.69 or later to resolve a NULL pointer dereference vulnerability in the mod_xml2enc module that can be triggered by malicious backend servers. This vulnerability allows remote denial of service attacks when Apache proxies responses with partially-failed character set conversions. Ensure all systems running Apache versions 2.4.0 through 2.4.68 are patched immediately, especially those operating as reverse proxies or handling content transformation.

sudo dnf update httpd httpd-tools

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'apache2 -v' or 'httpd -v' to display the installed Apache version; versions 2.4.0 through 2.4.68 are vulnerable
  2. Check if mod_xml2enc is loaded by running 'apache2ctl -M | grep xml2enc' or 'httpd -M | grep xml2enc'; if present, the module is active
  3. Search Apache error logs for segmentation faults or core dumps correlated with proxied XML/charset responses: grep -i 'segfault\|core dump\|sigsegv' /var/log/apache2/error.log
  4. Verify the patched version is running by restarting Apache with 'sudo systemctl restart apache2' and re-running 'apache2 -v' to confirm version 2.4.69 or later

FAQ

What is CVE-2026-63686?

CVE-2026-63686 is a NULL pointer dereference flaw in Apache's mod_xml2enc module that occurs when a proxied response contains a character set conversion that partially succeeds before failing. An attacker controlling a backend server can exploit this to crash the Apache process, causing denial of service.

Is CVE-2026-63686 being actively exploited?

No, CVE-2026-63686 is not listed in CISA's Known Exploited Vulnerabilities catalog, and no public exploit code is currently available. However, the vulnerability is straightforward to trigger and should be patched proactively.

What versions of Apache are affected by CVE-2026-63686?

All Apache HTTP Server versions from 2.4.0 through 2.4.68 are vulnerable. Version 2.4.69 and later contain the fix.

How do I check if my server is vulnerable to CVE-2026-63686?

Run 'apache2 -v' or 'httpd -v' and verify the version number. If it reports 2.4.68 or earlier, your server is vulnerable. Additionally, confirm mod_xml2enc is enabled by running 'apache2ctl -M | grep xml2enc' or equivalent on your platform.

Does Defensia detect CVE-2026-63686?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-63686 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63686. Free for 1 server.

Get started free