high CVSS 7.5 EPSS 0.47%

CVE-2026-63045·Apache vulnerability

Improper validation of FTP PASV reply address in mod_proxy_ftp in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows, in forward proxy configurations, an untrusted FTP server to cause the proxy to open a data connection to an arbitrary third-party host via a crafted PASV response. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.69
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.47% — higher than 39% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-63045 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.47%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.69

Fixed in: 2.4.69

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.69 or later to patch the FTP PASV reply validation flaw in mod_proxy_ftp. This vulnerability allows a malicious FTP server to redirect proxy connections to arbitrary third-party hosts when Apache is configured as a forward proxy. Immediate patching is recommended for any environment running Apache with FTP proxy capabilities enabled.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Apache version with: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS). Vulnerable if version is 2.4.0 through 2.4.68
  2. Step 2: Verify if mod_proxy_ftp is loaded by running: apache2ctl -M | grep proxy_ftp (Ubuntu/Debian) or httpctl -M | grep proxy_ftp (RHEL/CentOS)
  3. Step 3: Search Apache error and access logs for FTP PASV responses from untrusted servers: grep -i 'PASV\|227' /var/log/apache2/access.log or /var/log/httpd/access_log
  4. Step 4: After upgrading, verify the new version: apache2ctl -v or httpd -v should report 2.4.69 or higher

FAQ

What is CVE-2026-63045?

This vulnerability affects Apache's mod_proxy_ftp module, which handles FTP protocol proxying. An attacker controlling a malicious FTP server can craft a special PASV response that tricks Apache into opening data connections to unintended third-party hosts, potentially leading to information disclosure or internal network scanning.

Is CVE-2026-63045 being actively exploited?

No, this vulnerability is not currently listed on CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the attack requires low complexity and no user interaction, so prompt patching is still essential.

What versions of Apache are affected by CVE-2026-63045?

Apache HTTP Server versions 2.4.0 through 2.4.68 are vulnerable. Version 2.4.69 and later include the fix.

How do I check if my server is vulnerable to CVE-2026-63045?

Run 'httpd -v' or 'apache2ctl -v' to see your Apache version. If it shows 2.4.68 or earlier, and mod_proxy_ftp is enabled (check with 'httpd -M | grep proxy_ftp'), your server is vulnerable.

Does Defensia detect CVE-2026-63045?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-63045 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-63045. Free for 1 server.

Get started free