high CVSS 7.5 EPSS 0.50%

CVE-2026-59685·Apache vulnerability

Out-of-bounds Write vulnerability in Apache HTTP Server on Windows while processing paths with 8.3 names that may grow when expanded. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

Severity
high
Software
Apache
Fixed in
2.4.69
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.50% — higher than 41% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-59685 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.50%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.69

Fixed in: 2.4.69

How to fix this CVE

Apache HTTP Server versions 2.4.0 through 2.4.68 contain a memory safety vulnerability in Windows path processing that could allow information disclosure. Upgrade to Apache 2.4.69 or later immediately to patch the out-of-bounds write condition triggered by DOS 8.3 filename expansion. Verify the update completes successfully and restart the Apache service to ensure the patched version is running.

sudo dnf update -y httpd; sudo systemctl restart httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Apache version with `apache2 -v` (Ubuntu/Debian) or `httpd -v` (RHEL/CentOS/Amazon Linux) and confirm it is 2.4.69 or later
  2. Step 2: Verify the installed package version with `apt show apache2` (Debian-based) or `dnf list installed httpd` (RPM-based) to confirm patch level
  3. Step 3: Search Apache error logs (`/var/log/apache2/error.log` or `/var/log/httpd/error_log`) for segmentation faults or memory access violations occurring in mod_core or path processing modules
  4. Step 4: After upgrade, restart Apache with `sudo systemctl restart apache2` or `sudo systemctl restart httpd`, then confirm service is running and listening with `sudo ss -tulpn | grep :80`

FAQ

What is CVE-2026-59685?

This vulnerability is an out-of-bounds memory write in Apache HTTP Server's Windows path handling routines when processing DOS 8.3 format filenames that expand beyond their short-name representation. On affected Windows systems, this can lead to information disclosure.

Is CVE-2026-59685 being actively exploited?

No, this vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is currently available. However, it should still be patched promptly due to its high CVSS score of 7.5.

What versions of Apache are affected by CVE-2026-59685?

Apache HTTP Server versions 2.4.0 through 2.4.68 are vulnerable. The vulnerability is fixed in version 2.4.69 and later.

How do I check if my server is vulnerable to CVE-2026-59685?

Run `apache2 -v` or `httpd -v` and check the version number. If it shows 2.4.68 or earlier, your server is vulnerable and requires immediate patching.

Does Defensia detect CVE-2026-59685?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-59685 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-59685. Free for 1 server.

Get started free