high CVSS 7.5 EPSS 0.61%

CVE-2026-56449·Apache vulnerability

Out-of-bounds Write vulnerability in Apache HTTP Server's mod_proxy_html with crafted HTTP response bodies. This issue affects Apache HTTP Server version 2.4.68.

Severity
high
Software
Apache
Fixed in
2.4.69
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.61% — higher than 48% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-56449 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.61%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.69

Fixed in: 2.4.69

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.69 or later to patch the out-of-bounds write vulnerability in mod_proxy_html that can be triggered by malicious HTTP response bodies. Organizations should prioritize this update as the vulnerability affects all versions from 2.4.0 through 2.4.68 and can lead to memory corruption when the proxy_html module processes untrusted responses from upstream servers.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST/GET requests to proxied endpoints followed by HTTP 5xx errors or segmentation fault entries in error logs; look for malformed Content-Type headers or extremely large Content-Length values in upstream responses that trigger buffer overflows in HTML rewriting logic

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement a WAF rule to validate and sanitize HTTP response Content-Length headers from upstream servers; limit the maximum size of HTML response bodies processed by mod_proxy_html to prevent triggering out-of-bounds writes

How to check if you are affected

  1. Step 1: Check Apache version with `apachectl -v` or `apache2ctl -v` and verify it is 2.4.69 or later
  2. Step 2: Confirm mod_proxy_html is loaded by running `apache2ctl -M | grep proxy_html` (Ubuntu/Debian) or `httpd -M | grep proxy_html` (RHEL/CentOS)
  3. Step 3: Search Apache error logs for segmentation faults or memory-related errors: `grep -i 'segfault\|out of bounds\|memory' /var/log/apache2/error.log` or equivalent path
  4. Step 4: After patching, restart Apache with `sudo systemctl restart apache2` (Ubuntu/Debian) or `sudo systemctl restart httpd` (RHEL/CentOS) and verify no errors in logs

FAQ

What is CVE-2026-56449?

CVE-2026-56449 is a high-severity out-of-bounds write vulnerability in Apache HTTP Server's mod_proxy_html module that occurs when processing specially crafted HTTP response bodies from upstream servers, potentially leading to server crashes or memory corruption.

Is CVE-2026-56449 being actively exploited?

No, according to CISA KEV data, CVE-2026-56449 is not currently being actively exploited in the wild, though the vulnerability should still be remediated promptly due to its high CVSS score of 7.5.

What versions of Apache are affected by CVE-2026-56449?

Apache HTTP Server versions 2.4.0 through 2.4.68 are vulnerable. The vulnerability is patched in version 2.4.69 and later.

How do I check if my server is vulnerable to CVE-2026-56449?

Run `apachectl -v` (or `apache2ctl -v` on Debian/Ubuntu) to confirm your version is between 2.4.0 and 2.4.68, then check if mod_proxy_html is enabled with `apache2ctl -M | grep proxy_html` or `httpd -M | grep proxy_html`.

Does Defensia detect CVE-2026-56449?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-56449 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-56449. Free for 1 server.

Get started free