CVE-2026-53362·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: ipv6: account for fraggap on the paged allocation path In __ip6_append_data(), when the paged-allocation branch is taken (MSG_MORE / NETIF_F_SG / large fraglen), alloclen and pagedlen are computed as alloclen = fragheaderlen + transhdrlen; pagedlen = datalen - transhdrlen; datalen already includes fraggap (datalen = length + fraggap). When fraggap is non-zero, this is not the first skb and transhdrlen is zero. The fraggap bytes carried over from the previous skb are copied just past the fragment headers in the new skb's linear area. The linear area is therefore undersized by fraggap bytes while pagedlen is overstated by the same amount, and the copy writes past skb->end into the trailing skb_shared_info. An unprivileged user can trigger this via a UDPv6 socket using MSG_MORE together with MSG_SPLICE_PAGES. The bad accounting was introduced by commit 773ba4fe9104 ("ipv6: avoid partial copy for zc"). Before commit ce650a166335 ("udp6: Fix __ip6_append_data()'s handling of MSG_SPLICE_PAGES"), the negative copy value caused -EINVAL to be returned. That later commit allowed MSG_SPLICE_PAGES to proceed in this case, making the corruption triggerable. The non-paged branch sets alloclen to fraglen, which already accounts for fraggap because datalen does. Bring the paged branch in line by adding fraggap to alloclen and subtracting it from pagedlen. After this adjustment, copy no longer collapses to -fraggap on the paged path, so remove the stale comment describing that old arithmetic. Since a negative copy is no longer expected for a valid MSG_SPLICE_PAGES case, remove the MSG_SPLICE_PAGES exception from the negative copy check.
- Severity
- high
- Software
- Kernel
- Fixed in
- 7.1.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.71% — higher than 52% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-53362 scores 7.8 on CVSS, so a successful attack would be serious — but at 0.71%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 6.19
Until: 7.1.3
Fixed in: 7.1.3
How to fix this CVE
Update your Linux kernel to version 7.1.3 or later to resolve a memory corruption vulnerability in IPv6 packet fragmentation handling. This flaw affects the paged allocation path when using UDP over IPv6 with MSG_MORE and MSG_SPLICE_PAGES flags, allowing local unprivileged users to write past allocated buffer boundaries. Kernel updates should be applied promptly and followed by a system reboot to activate the patched version.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Check current kernel version: uname -r (verify it is not in the 6.19.x–7.1.2 range)
- Verify IPv6 stack is loaded: lsmod | grep ipv6 (if present, the vulnerable code path is available)
- Monitor for application crashes or memory corruption: dmesg | grep -i 'memory corruption\|segfault\|kernel panic' (look for recent entries suggesting buffer overflow)
- Confirm fix applied: After reboot, run uname -r and verify version is 7.1.3 or later
FAQ
What is CVE-2026-53362?
This vulnerability is a memory corruption flaw in the Linux kernel's IPv6 fragmentation logic that incorrectly calculates buffer sizes when handling paginated allocations with the MSG_MORE flag, causing writes beyond allocated memory boundaries.
Is CVE-2026-53362 being actively exploited?
Yes—this vulnerability is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, indicating active exploitation in the wild.
What versions of Kernel are affected by CVE-2026-53362?
Linux kernel versions 6.19 through 7.1.2 are vulnerable; version 7.1.3 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-53362?
Run uname -r to display your kernel version—if it falls between 6.19.0 and 7.1.2 (inclusive), your system is vulnerable and requires an immediate kernel update.
Does Defensia detect CVE-2026-53362?
Yes—Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-53362 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/14200d435af9a9eeb444f529fc2f689a236b7962
- https://git.kernel.org/stable/c/46f201f8b4c39633a1fa3dc12459f506d470993d
- https://git.kernel.org/stable/c/6374fb9edf72c67a118a2c214a0dddd04c921e0a
- https://git.kernel.org/stable/c/65fb14cbebb0cd0eff903a22d33537ddc8b95769
- https://git.kernel.org/stable/c/736b380e28d0480c7bc3e022f1950f31fe53a7c5
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-53362. Free for 1 server.
Get started free