CVE-2026-53055·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: crypto: hisilicon/sec2 - prevent req used-after-free for sec During packet transmission, if the system is under heavy load, the hardware might complete processing the packet and free the request memory (req) before the transmission function finishes. If the software subsequently accesses this req, a use-after-free error will occur. The qp_ctx memory exists throughout the packet sending process, so replace the req with the qp_ctx.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 7.0.10
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.43% — higher than 37% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-53055 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.43%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 6.19
Until: 7.0.10
Fixed in: 7.0.10
How to fix this CVE
Update your Linux kernel to version 7.0.10 or later to remediate this critical use-after-free vulnerability in the HiSilicon SEC2 crypto driver. The vulnerability occurs when hardware completes packet processing and frees request memory before the transmission function finishes, leading to potential memory corruption and system compromise. Apply the kernel update immediately and reboot your system to ensure the fix is active.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Check the installed kernel version: uname -r | grep -E '^[6-7]\.' && echo 'Kernel version detected'
- Verify if HiSilicon SEC2 driver is loaded: lsmod | grep hisi_sec2 && echo 'SEC2 driver is active' || echo 'SEC2 not loaded'
- Monitor dmesg for memory corruption or use-after-free warnings: sudo dmesg | grep -i 'use-after-free\|sec2\|memory corruption' | tail -20
- Confirm the kernel version is at least 7.0.10: uname -r | awk -F'.' '{if ($1 >= 7 && $2 >= 0 && $3 >= 10) print "Patched"; else print "Vulnerable"}'
FAQ
What is CVE-2026-53055?
This is a critical use-after-free vulnerability in the Linux kernel's HiSilicon SEC2 cryptographic accelerator driver. Under heavy system load, the hardware may complete packet processing and deallocate request memory before the software transmission function finishes accessing it, leading to memory corruption and potential system compromise.
Is CVE-2026-53055 being actively exploited?
No, according to CISA's Known Exploited Vulnerabilities (KEV) database, CVE-2026-53055 is not currently being actively exploited in the wild, and no public exploits are available.
What versions of Kernel are affected by CVE-2026-53055?
Linux kernel versions 6.19 through 7.0.9 are vulnerable. The fix is included in kernel version 7.0.10 and later.
How do I check if my server is vulnerable to CVE-2026-53055?
Run `uname -r` to check your kernel version. If it shows a version between 6.19 and 7.0.9, you are vulnerable. Additionally, verify SEC2 driver presence with `lsmod | grep hisi_sec2`.
Does Defensia detect CVE-2026-53055?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-53055 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-53055. Free for 1 server.
Get started free