CVE-2026-49975·Nginx vulnerability
Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.
- Severity
- critical
- Software
- Nginx
- Fixed in
- 1.4.6-1ubuntu3.9+esm8
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 4.2% — in the top 9% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
Until: 1.4.6-1ubuntu3.9+esm8
Fixed in: 1.4.6-1ubuntu3.9+esm8
How to fix this CVE
Update Nginx to version 1.4.6-1ubuntu3.9+esm8 or later to patch a memory allocation vulnerability that can trigger denial of service conditions. This issue stems from improper handling of oversized HTTP requests that cause excessive memory allocation in the HTTP/2 module. Apply this update immediately across all affected systems to restore service stability.
sudo dnf update nginxDefensia detects this vulnerability
WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement HTTP/2 frame size limits at the WAF or reverse proxy to reject oversized SETTINGS_MAX_FRAME_SIZE values and DATA frames exceeding 16KB; rate-limit clients sending abnormally large header blocks (detected via CONTINUATION frames) to throttle HTTP/2 bomb attacks.How to check if you are affected
- Step 1: Check installed Nginx version with `nginx -v` or `dpkg -l | grep nginx` on Debian/Ubuntu, or `rpm -q nginx` on RHEL/CentOS
- Step 2: Verify HTTP/2 support is enabled by checking Nginx configuration with `nginx -T | grep http2` and confirming the listen directive includes http2
- Step 3: Monitor Nginx error logs for out-of-memory (OOM) killer invocations or allocation failures: `grep -i 'memory\|allocation\|oom' /var/log/nginx/error.log`
- Step 4: After patching, confirm the updated version with `nginx -v` and reload Nginx with `sudo systemctl reload nginx`, then verify the service is running with `systemctl status nginx`
FAQ
What is CVE-2026-49975?
CVE-2026-49975 is a memory allocation vulnerability in Nginx's HTTP/2 module that permits attackers to send specially crafted HTTP requests triggering unbounded memory allocation, resulting in denial of service through resource exhaustion or system crash.
Is CVE-2026-49975 being actively exploited?
No, CVE-2026-49975 is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though the critical CVSS score warrants urgent patching.
What versions of Nginx are affected by CVE-2026-49975?
Nginx versions from unknown through 1.4.6-1ubuntu3.9+esm8 are affected; the fixed version is 1.4.6-1ubuntu3.9+esm8 and later patches.
How do I check if my server is vulnerable to CVE-2026-49975?
Run `nginx -v` to retrieve your installed version, then cross-reference against 1.4.6-1ubuntu3.9+esm8; if your version is older, your system is vulnerable. Additionally confirm HTTP/2 is enabled with `nginx -T | grep http2`.
Does Defensia detect CVE-2026-49975?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Nginx is installed on a monitored server, CVE-2026-49975 will appear in your dashboard with remediation steps.
Related Nginx CVEs
References
- https://ubuntu.com/security/CVE-2026-49975
- https://www.cve.org/CVERecord?id=CVE-2026-49975
- https://blog.calif.io/p/codex-discovered-a-hidden-http2-bomb
- https://github.com/icing/mod_h2/pull/324
- https://ubuntu.com/security/notices/USN-8384-1
- https://ubuntu.com/security/notices/USN-8398-1
- https://ubuntu.com/security/notices/USN-8398-2
- https://ubuntu.com/security/notices/USN-8398-3
- https://ubuntu.com/security/notices/USN-8571-1
- https://ubuntu.com/security/notices/USN-8398-4
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-49975. Free for 1 server.
Get started free