critical CVSS 9 Actively exploited EPSS 100% Public exploit available

CVE-2023-44487·Nginx vulnerability

The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023.

Severity
critical
Software
Nginx
Fixed in
1.8.2-2
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 100% — among the highest-scoring CVEs ever published. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 1.8.2-2

Fixed in: 1.8.2-2

How to fix this CVE

Update Nginx to version 1.8.2-2 or later to patch the HTTP/2 stream reset vulnerability that enables rapid resource exhaustion attacks. This critical flaw allows attackers to trigger excessive server CPU and memory consumption by repeatedly canceling HTTP/2 streams. Immediate patching is essential as this vulnerability is actively exploited in the wild.

sudo dnf update nginx

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

Multiple rapid HTTP/2 stream cancellations within a short time window (e.g., >50 RST_STREAM frames per second from a single source) in Nginx error logs: `error.*RST_STREAM` or connection reset patterns appearing in bursts from the same client IP

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement HTTP/2 stream rate limiting at the WAF or reverse proxy level. Configure Nginx directives such as `http2_max_concurrent_streams` to a lower value (e.g., 16-32) and monitor for abnormal stream reset patterns. Apply rate limits per client IP to prevent rapid stream cycling.

How to check if you are affected

  1. Run `nginx -v` to check your installed Nginx version and confirm if it is below 1.8.2-2
  2. Verify HTTP/2 support is enabled by checking `grep -i 'http2' /etc/nginx/nginx.conf` or your site configuration files
  3. Search Nginx access and error logs for rapid RST_STREAM frames or connection resets: `grep -E '(RST_STREAM|stream reset|PROTOCOL_ERROR)' /var/log/nginx/error.log | tail -100`
  4. After patching, run `nginx -v` again to confirm the version is 1.8.2-2 or newer, then reload with `sudo systemctl reload nginx`

FAQ

What is CVE-2023-44487?

CVE-2023-44487 is a critical HTTP/2 protocol flaw that permits attackers to exhaust server resources by rapidly resetting multiple HTTP/2 streams, causing denial of service through CPU and memory saturation.

Is CVE-2023-44487 being actively exploited?

Yes, this vulnerability is actively exploited in the wild and has been documented on the CISA KEV catalog. Public exploits became available starting in August 2023.

What versions of Nginx are affected by CVE-2023-44487?

All Nginx versions prior to 1.8.2-2 are vulnerable. The vulnerability exists in the HTTP/2 implementation and affects any build shipping unpatched HTTP/2 support.

How do I check if my server is vulnerable to CVE-2023-44487?

Run `nginx -v` to see your version. If it displays a version older than 1.8.2-2 and HTTP/2 is enabled in your configuration, your server is vulnerable.

Does Defensia detect CVE-2023-44487?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Nginx is installed on a monitored server, CVE-2023-44487 will appear in your dashboard with remediation steps.

Related Nginx CVEs

CVE-2009-3555CVSS 10The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft Internet Information Services (IIS) 7.0, mod_ssl in the Apache HTTP Server 2.2.14 and earlier, OpenSSL before 0.9.8l, GnuTLS 2.8.5 and earlier, Mozilla Network Security Services (NSS) 3.12.4 and earlier, multiple Cisco products, and other products, does not properly associate renegotiation handshakes with an existing connection, which allows man-in-the-middle attackers to insert data into HTTPS sessions, and possibly other types of sessions protected by TLS or SSL, by sending an unauthenticated request that is processed retroactively by a server in a post-renegotiation context, related to a "plaintext injection" attack, aka the "Project Mogul" issue.
CVE-2021-23017CVSS 9A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.
CVE-2026-42946CVSS 9A vulnerability exists in the ngx_http_scgi_module and ngx_http_uwsgi_module modules that may result in excessive memory allocation or an over-read of data. When scgi_pass or uwsgi_pass is configured, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to read the memory of the NGINX worker process or restart it.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVE-2026-60005CVSS 9NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVE-2026-49975CVSS 9Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2023-44487. Free for 1 server.

Get started free