critical CVSS 9 EPSS 53% Public exploit available

CVE-2021-23017·Nginx vulnerability

A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.

Severity
critical
Software
Nginx
Fixed in
1.18.0-6.1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 53% — in the top 1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 1.18.0-6.1

Fixed in: 1.18.0-6.1

How to fix this CVE

Update Nginx to version 1.18.0-6.1 or later to patch a critical DNS resolver vulnerability that allows remote attackers to trigger a single-byte memory overwrite via crafted UDP packets. This flaw can lead to worker process crashes and potential privilege escalation. Prioritize this update immediately as public exploits are available.

sudo dnf update nginx

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Nginx version: nginx -v
  2. Verify DNS resolver is enabled in Nginx config: grep -r 'resolver' /etc/nginx/
  3. Search Nginx error logs for segmentation faults or worker crashes: grep -i 'segmentation\|worker.*crashed' /var/log/nginx/error.log
  4. Confirm update by running nginx -v again and verifying version is 1.18.0-6.1 or later

FAQ

What is CVE-2021-23017?

A critical vulnerability in Nginx's DNS resolver component that permits attackers sending forged DNS responses to corrupt memory by exactly one byte, destabilizing worker processes and potentially enabling code execution.

Is CVE-2021-23017 being actively exploited?

While not listed in CISA's actively exploited vulnerabilities catalog, public proof-of-concept exploits are available, making active exploitation a realistic threat.

What versions of Nginx are affected by CVE-2021-23017?

All versions prior to and including 1.18.0-6.1 are vulnerable. Installations using the DNS resolver feature are at highest risk.

How do I check if my server is vulnerable to CVE-2021-23017?

Run 'nginx -v' to get your version and compare against 1.18.0-6.1. Then check if DNS resolution is configured: 'grep resolver /etc/nginx/*.conf /etc/nginx/conf.d/*.conf' — if results appear, your setup is exposed.

Does Defensia detect CVE-2021-23017?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Nginx is installed on a monitored server, CVE-2021-23017 will appear in your dashboard with remediation steps.

Related Nginx CVEs

CVE-2009-3555CVSS 10The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft Internet Information Services (IIS) 7.0, mod_ssl in the Apache HTTP Server 2.2.14 and earlier, OpenSSL before 0.9.8l, GnuTLS 2.8.5 and earlier, Mozilla Network Security Services (NSS) 3.12.4 and earlier, multiple Cisco products, and other products, does not properly associate renegotiation handshakes with an existing connection, which allows man-in-the-middle attackers to insert data into HTTPS sessions, and possibly other types of sessions protected by TLS or SSL, by sending an unauthenticated request that is processed retroactively by a server in a post-renegotiation context, related to a "plaintext injection" attack, aka the "Project Mogul" issue.
CVE-2023-44487CVSS 9The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023.
CVE-2026-42946CVSS 9A vulnerability exists in the ngx_http_scgi_module and ngx_http_uwsgi_module modules that may result in excessive memory allocation or an over-read of data. When scgi_pass or uwsgi_pass is configured, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to read the memory of the NGINX worker process or restart it.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVE-2026-60005CVSS 9NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVE-2026-49975CVSS 9Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2021-23017. Free for 1 server.

Get started free