high CVSS 8.5

CVE-2026-48913·Apache vulnerability

Use After Free vulnerability in Apache HTTP Server module mod_http2 when file handles are already exhausted. This issue affects Apache HTTP Server: from 2.4.55 through 2.4.67.

Severity
high
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Update Apache HTTP Server to version 2.4.68-1~deb12u1 or later to patch the use-after-free vulnerability in mod_http2. This vulnerability can lead to crashes or potential memory corruption when the server is under high load and file descriptor limits are reached. Apply the update as soon as possible to prevent stability issues and mitigate the risk of exploitation.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Apache version: apache2ctl -v | grep 'Server version'
  2. Verify mod_http2 is loaded: apache2ctl -M | grep http2
  3. Monitor system file descriptor limits during high traffic: cat /proc/sys/fs/file-max
  4. Confirm patched version is running: apache2ctl -v | grep -E '2\.4\.(6[8-9]|[7-9][0-9])'
  5. Review Apache error logs for segmentation faults: grep -i 'segmentation\|core dump' /var/log/apache2/error.log

FAQ

What is CVE-2026-48913?

This is a use-after-free vulnerability in Apache's mod_http2 module that occurs when file handles are exhausted, potentially allowing memory corruption or denial of service under resource-constrained conditions.

Is CVE-2026-48913 being actively exploited?

No, this vulnerability is not currently listed as actively exploited according to CISA's KEV catalog, and no public exploits are available.

What versions of Apache are affected by CVE-2026-48913?

Apache HTTP Server versions 2.4.55 through 2.4.67 are vulnerable. Version 2.4.68-1~deb12u1 and later contain the fix.

How do I check if my server is vulnerable to CVE-2026-48913?

Run 'apache2ctl -v' and check if your version falls between 2.4.55 and 2.4.67. Additionally, verify mod_http2 is loaded with 'apache2ctl -M | grep http2'.

Does Defensia detect CVE-2026-48913?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-48913 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-48913. Free for 1 server.

Get started free