high CVSS 8.5 EPSS 1.1%

CVE-2026-44186·Apache vulnerability

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in the mod_proxy_ftp module in Apache HTTP Server with an attacker controlled backend FTP server. This issue affects undefined: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Severity
high
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.1% — higher than 64% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Update Apache HTTP Server to version 2.4.68 or later to patch the infinite loop vulnerability in mod_proxy_ftp. This vulnerability can be triggered when Apache forwards FTP requests to a malicious backend FTP server, potentially causing service degradation or denial of service. Administrators should prioritize this update, especially if mod_proxy_ftp is actively used in their deployment.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Apache version — Run: apache2ctl -v (Debian/Ubuntu) or httpd -v (RHEL/CentOS) and confirm if version is below 2.4.68
  2. Step 2: Verify mod_proxy_ftp is loaded — Run: apache2ctl -M | grep proxy_ftp (Debian/Ubuntu) or httpctl -M | grep proxy_ftp (RHEL/CentOS)
  3. Step 3: Review Apache configuration for FTP proxy directives — Run: grep -r 'ProxyPass.*ftp://' /etc/apache2/sites-enabled/ (Debian/Ubuntu) or /etc/httpd/conf.d/ (RHEL/CentOS)
  4. Step 4: Verify the patch is installed — Run: dpkg -l | grep apache2 (Debian/Ubuntu) or rpm -qa | grep httpd (RHEL/CentOS) and confirm version shows 2.4.68 or later

FAQ

What is CVE-2026-44186?

CVE-2026-44186 is an infinite loop vulnerability in Apache's mod_proxy_ftp module that can be triggered when processing requests through a malicious FTP backend server. An attacker controlling the backend server can craft responses that cause the Apache process to enter an endless loop, leading to resource exhaustion and service unavailability.

Is CVE-2026-44186 being actively exploited?

No. This vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities catalog, and no public exploits are available. However, the high CVSS score (8.5) warrants timely patching.

What versions of Apache are affected by CVE-2026-44186?

Apache HTTP Server versions 2.4.0 through 2.4.67 are affected. Version 2.4.68 and later contain the fix.

How do I check if my server is vulnerable to CVE-2026-44186?

Run apache2ctl -v (Debian/Ubuntu) or httpd -v (RHEL/CentOS) to check your installed version. If it shows 2.4.67 or lower, and mod_proxy_ftp is enabled (apache2ctl -M | grep proxy_ftp), your server is vulnerable.

Does Defensia detect CVE-2026-44186?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-44186 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44186. Free for 1 server.

Get started free