CVE-2026-44173·MariaDB vulnerability
MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB allowed SELECT ... INTO OUTFILE and SELECT ... INTO DUMPFILE without verifying the FILE privilege if the FROM clause contained only subqueries. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.
- Severity
- medium
- Software
- MariaDB
- Fixed in
- 11.8.7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.40% — higher than 32% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 11.8.1
Until: 11.8.7
Fixed in: 11.8.7
How to fix this CVE
Update MariaDB to version 11.8.7 or later to patch a privilege bypass vulnerability affecting the SELECT ... INTO OUTFILE and SELECT ... INTO DUMPFILE operations. This vulnerability allowed users to write files to disk without the required FILE privilege when using subqueries, potentially leading to unauthorized data exfiltration or system compromise. Immediately apply the security patch to all affected MariaDB instances.
sudo dnf update mariadb-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your installed MariaDB version by running: mysql --version or mariadb --version
- Step 2: Connect to MariaDB and verify version: SELECT VERSION(); — versions 11.8.1 through 11.8.6 are vulnerable
- Step 3: Search MariaDB error logs for SELECT ... INTO OUTFILE and SELECT ... INTO DUMPFILE queries from users without FILE privilege: grep -i 'INTO OUTFILE\|INTO DUMPFILE' /var/log/mysql/error.log
- Step 4: After patching, confirm the update with SELECT VERSION(); and verify the patch version is 11.8.7 or later
FAQ
What is CVE-2026-44173?
This is a privilege escalation vulnerability in MariaDB where users could bypass FILE privilege restrictions by crafting SELECT statements that write to disk using subqueries in the FROM clause, enabling unauthorized file operations.
Is CVE-2026-44173 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is available.
What versions of MariaDB are affected by CVE-2026-44173?
Multiple release branches are impacted: 10.6.1 to 10.6.25, 10.11.1 to 10.11.16, 11.4.1 to 11.4.10, 11.8.1 to 11.8.6, and 12.3.1. For the 11.8 branch specifically, versions 11.8.1 through 11.8.6 are vulnerable.
How do I check if my server is vulnerable to CVE-2026-44173?
Connect to MariaDB and run: SELECT VERSION(); If the version is between 11.8.1 and 11.8.6, your server is vulnerable and requires immediate patching to 11.8.7 or later.
Does Defensia detect CVE-2026-44173?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-44173 will appear in your dashboard with remediation steps.
Related MariaDB CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44173. Free for 1 server.
Get started free