critical CVSS 9.1 EPSS 0.40%

CVE-2026-44172·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. In versions 3.3.18 and 3.4.8, an application that was taking non-validated user input, escaping it with mysql_real_escape_string() and sending it to the database using text protocol and big5 character set was vulnerable to SQL injections, even though mysql_real_escape_string() was supposed to prevent them. This issue has been patched in versions 3.3.19 and 3.4.9.

Severity
critical
Software
MariaDB
Fixed in
1:10.11.18-0+deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.40% — higher than 32% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-44172 scores 9.1 on CVSS, so a successful attack would be serious — but at 0.40%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 1:10.11.18-0+deb12u1

Fixed in: 1:10.11.18-0+deb12u1

How to fix this CVE

MariaDB versions up to 10.11.18 contain a character encoding bypass in the mysql_real_escape_string() function that allows SQL injection when using the big5 character set, despite proper escaping. Immediately upgrade MariaDB to version 1:10.11.18-0+deb12u1 or later to apply the security patch that fixes this encoding validation issue.

sudo dnf update mariadb-server

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

SQL queries containing big5-encoded multi-byte sequences with backslash or quote characters (e.g., '0xbf27' followed by SQL keywords) in MariaDB slow query logs or audit logs; look for pattern: [0x81-0xfe][0x40-0xfe] followed by 0x27 or 0x5c in text protocol communications

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block requests with big5 character set encoding in Content-Type headers or URL parameters containing suspicious multi-byte sequences (0xbf27, 0x8e5c patterns); add charset normalization to UTF-8 before database queries; validate character set headers and reject big5 encoding if not explicitly required

How to check if you are affected

  1. Run 'mariadb --version' or 'mysql --version' to check the installed MariaDB version and confirm it is below 10.11.18
  2. Connect to MariaDB with 'mariadb -u root -p' and execute 'SHOW VARIABLES LIKE "character_set%";' to identify if big5 character set is in use
  3. Review application code for use of mysql_real_escape_string() function calls, particularly in queries handling user input with big5 encoding
  4. Run 'dpkg -l | grep mariadb' (Debian/Ubuntu) or 'dnf list installed mariadb-server' (RHEL/CentOS) and verify the package version matches or exceeds the patched version

FAQ

What is CVE-2026-44172?

This vulnerability exploits a flaw in MariaDB's mysql_real_escape_string() function when processing big5 character set encoding, allowing attackers to bypass SQL injection protections through carefully crafted multi-byte character sequences that manipulate quote escaping logic.

Is CVE-2026-44172 being actively exploited?

No, there are currently no reports of active exploitation or publicly available exploits for this vulnerability, though the critical CVSS score of 9.1 warrants immediate patching.

What versions of MariaDB are affected by CVE-2026-44172?

All MariaDB versions up to and including 10.11.18-0+deb12u1 are vulnerable when using the big5 character set. The fix is available in MariaDB 1:10.11.18-0+deb12u1 and later versions.

How do I check if my server is vulnerable to CVE-2026-44172?

Execute 'mariadb --version' to check your version number. If it shows a version below 10.11.18, your installation is vulnerable. Additionally, query 'SHOW VARIABLES WHERE variable_name = "character_set_client";' to confirm if big5 encoding is configured.

Does Defensia detect CVE-2026-44172?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-44172 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44172. Free for 1 server.

Get started free