high CVSS 8.5 EPSS 1.0%

CVE-2026-43951·Apache vulnerability

Out-of-bounds Read vulnerability in Apache HTTP Server with mod_headers and mod_mime and multiple response languages. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

Severity
high
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.0% — higher than 64% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Update Apache HTTP Server to version 2.4.68-1~deb12u1 or later to patch the out-of-bounds read vulnerability affecting mod_headers and mod_mime when processing multiple response language headers. This vulnerability can leak sensitive memory contents and should be prioritized in your patching cycle. Apply the update across all production and non-production Apache instances.

sudo dnf update httpd -y

Defensia detects this vulnerability

How to check if you are affected

  1. Check your Apache version: apache2ctl -v (Debian/Ubuntu) or httpd -v (RHEL/CentOS/AL2023)
  2. Verify mod_headers and mod_mime are loaded: apache2ctl -M | grep -E 'headers_module|mime_module' (verify both modules are listed)
  3. Search Apache access and error logs for unusual header patterns: grep -E 'Accept-Language|Content-Language' /var/log/apache2/error.log | head -50
  4. Confirm patched version: apt show apache2 2>/dev/null | grep Version (Debian/Ubuntu) or dnf info httpd (RHEL/CentOS)

FAQ

What is CVE-2026-43951?

This is an out-of-bounds memory read flaw in Apache HTTP Server that occurs when mod_headers and mod_mime process HTTP responses with multiple language headers. An attacker can craft malicious requests to read adjacent memory regions, potentially exposing sensitive data like session tokens or configuration secrets.

Is CVE-2026-43951 being actively exploited?

No, according to CISA's Known Exploited Vulnerabilities catalog, there is no evidence of active exploitation in the wild at this time. However, the high CVSS score (8.5) warrants immediate patching as proof-of-concept exploits could emerge.

What versions of Apache are affected by CVE-2026-43951?

Apache HTTP Server versions 2.4.0 through 2.4.67 are vulnerable. The fix is available in version 2.4.68-1~deb12u1 and later releases across all supported distributions.

How do I check if my server is vulnerable to CVE-2026-43951?

Run 'apache2ctl -v' or 'httpd -v' and check if the version is between 2.4.0 and 2.4.67. Additionally, confirm mod_headers and mod_mime are enabled with 'apache2ctl -M | grep -E headers_module|mime_module'. If both conditions are true, the server is vulnerable.

Does Defensia detect CVE-2026-43951?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-43951 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-43951. Free for 1 server.

Get started free