critical CVSS 9.5 EPSS 0.71%

CVE-2026-42535·Apache vulnerability

A path handling issue in mod_dav_fs in Apache 2.4.67 and earlier allows a WebDAV content author to directly manipulate trusted DAV property databases, potentially causing child process crashes. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

Severity
critical
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.71% — higher than 52% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-42535 scores 9.5 on CVSS, so a successful attack would be serious — but at 0.71%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Update Apache HTTP Server to version 2.4.68 or later to resolve a path handling vulnerability in the mod_dav_fs module that allows WebDAV authors to corrupt DAV property databases and trigger child process crashes. Organizations running Apache 2.4.67 or earlier with WebDAV enabled should prioritize this upgrade, as the vulnerability can lead to service disruption and potential data integrity issues. Apply the update during a maintenance window and verify normal WebDAV operations post-deployment.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'apache2ctl -v' (Debian/Ubuntu) or 'httpd -v' (RHEL/CentOS) and verify the version is 2.4.68 or later
  2. Execute 'apache2ctl -M | grep dav' (Debian/Ubuntu) or 'httpd -M | grep dav' (RHEL/CentOS) to confirm mod_dav_fs is loaded; if not present, the system is not vulnerable
  3. Check Apache error logs for messages containing 'dav_fs' and 'child process' or segmentation fault errors: 'grep -i "dav_fs\|child.*crash" /var/log/apache2/error.log'
  4. Verify the patch was applied by running 'dpkg -l | grep apache2' (Debian/Ubuntu) and confirming version 2.4.68-1~deb12u1 or later is installed

FAQ

What is CVE-2026-42535?

CVE-2026-42535 is a path handling defect in Apache's mod_dav_fs module that permits WebDAV content authors to manipulate trusted DAV property metadata files, resulting in child process instability and potential denial of service conditions.

Is CVE-2026-42535 being actively exploited?

No, CVE-2026-42535 is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits have been disclosed. However, the critical CVSS 9.5 score warrants immediate patching.

What versions of Apache are affected by CVE-2026-42535?

All versions of Apache HTTP Server up to and including 2.4.67 are vulnerable. Version 2.4.68 and later contain the remediation.

How do I check if my server is vulnerable to CVE-2026-42535?

Run 'apache2ctl -v' (or 'httpd -v' on RHEL/CentOS) and compare the version string against 2.4.67; if your version is 2.4.67 or earlier and mod_dav_fs is enabled (verify with 'apache2ctl -M | grep dav_fs'), your system is vulnerable.

Does Defensia detect CVE-2026-42535?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-42535 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-42535. Free for 1 server.

Get started free