CVE-2026-34356·Apache vulnerability
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie* This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
- Severity
- critical
- Software
- Apache
- Fixed in
- 2.4.68-1~deb12u1
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.2% — higher than 68% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
Until: 2.4.68-1~deb12u1
Fixed in: 2.4.68-1~deb12u1
How to fix this CVE
Apache HTTP Server versions 2.4.0 through 2.4.67 contain a heap buffer overflow vulnerability triggered when processing specially crafted responses from malicious backend servers, particularly when ProxyPassReverseCookie directives are active. Upgrade to Apache 2.4.68 or later immediately to eliminate this memory corruption flaw that can lead to denial of service or potential code execution. Verify the patched version is running and review your proxy configurations to ensure reverse cookie rewriting is only enabled where necessary.
sudo dnf update httpdDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST/GET requests to proxy endpoints followed by abnormal backend responses with oversized Set-Cookie or Cookie headers; look for patterns like 'Set-Cookie:.*\x00.*\x00' or responses exceeding 8192 bytes in cookie-related headers in proxy logsWAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement WAF rules to limit the size of Set-Cookie and Cookie headers from backend responses; block any responses with null bytes in cookie values; enforce strict Content-Length validation on upstream proxy responsesHow to check if you are affected
- Check installed Apache version: apache2ctl -v | grep 'Server version'
- Verify if mod_proxy and ProxyPassReverseCookie directives are enabled: grep -r 'ProxyPassReverseCookie' /etc/apache2/sites-enabled/ /etc/apache2/conf-enabled/
- Search Apache error and access logs for unusual backend server responses or memory-related errors: grep -i 'segmentation\|buffer\|overflow' /var/log/apache2/error.log
- Confirm the fix by checking: apache2ctl -v and verifying version is >= 2.4.68
FAQ
What is CVE-2026-34356?
CVE-2026-34356 is a heap-based buffer overflow in Apache HTTP Server that occurs during the processing of cookie rewriting responses from backend proxy servers. When a malicious backend server sends specially crafted data, it can overflow heap memory in the reverse proxy handler, potentially causing a denial of service or information disclosure.
Is CVE-2026-34356 being actively exploited?
No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities catalog, and no public exploits have been disclosed. However, its critical CVSS score of 9.0 and denial-of-service impact warrant immediate patching.
What versions of Apache are affected by CVE-2026-34356?
Apache HTTP Server versions 2.4.0 through 2.4.67 are vulnerable. The vulnerability is fixed in version 2.4.68 and later.
How do I check if my server is vulnerable to CVE-2026-34356?
Run 'apache2ctl -v' or 'httpd -v' to display your Apache version. If it reports a version between 2.4.0 and 2.4.67, you are vulnerable. Also confirm that mod_proxy is loaded with 'apache2ctl -M | grep proxy' and check for ProxyPassReverseCookie usage in your configuration.
Does Defensia detect CVE-2026-34356?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-34356 will appear in your dashboard with remediation steps.
Related Apache CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-34356. Free for 1 server.
Get started free