high CVSS 7.5 EPSS 0.95%

CVE-2026-34059·Apache vulnerability

Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Severity
high
Software
Apache
Fixed in
2.4.67
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.95% — higher than 61% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-34059 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.95%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.67

Fixed in: 2.4.67

How to fix this CVE

Apache HTTP Server versions up to 2.4.66 contain a buffer over-read vulnerability that could allow unauthenticated attackers to access sensitive memory. Immediately upgrade to Apache 2.4.67 or later to patch this high-severity issue. Prioritize this update for all internet-facing web servers running affected versions.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Apache version: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS/Amazon Linux) — confirm if version is ≤ 2.4.66
  2. Verify active Apache modules: apache2ctl -M (Ubuntu/Debian) or httpd -M (RHEL/CentOS) to identify if core HTTP processing modules are loaded
  3. Search Apache access and error logs for unusual patterns: grep -i 'buffer\|memory\|segfault' /var/log/apache2/error.log or /var/log/httpd/error_log
  4. Confirm patch application: apache2ctl -v or httpd -v should show version 2.4.67 or higher; verify with dpkg -l apache2 or rpm -qa httpd

FAQ

What is CVE-2026-34059?

CVE-2026-34059 is a buffer over-read vulnerability in Apache HTTP Server that permits attackers without authentication to read sensitive data from server memory. This occurs due to insufficient bounds checking in HTTP request processing.

Is CVE-2026-34059 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available at this time.

What versions of Apache are affected by CVE-2026-34059?

All Apache HTTP Server versions from the earliest release up to and including 2.4.66 are affected. Apache 2.4.67 and later versions contain the fix.

How do I check if my server is vulnerable to CVE-2026-34059?

Run apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS/Amazon Linux). If the version displayed is 2.4.66 or lower, your server is vulnerable and requires immediate patching.

Does Defensia detect CVE-2026-34059?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-34059 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-34059. Free for 1 server.

Get started free