CVE-2026-31431·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: crypto: algif_aead - Revert to operating out-of-place This mostly reverts commit 72548b093ee3 except for the copying of the associated data. There is no benefit in operating in-place in algif_aead since the source and destination come from different mappings. Get rid of all the complexity added for in-place operation and just copy the AD directly.
- Severity
- high
- Software
- Kernel
- Fixed in
- 6.19.12
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 3.4% — higher than 89% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 6.19
Until: 6.19.12
Fixed in: 6.19.12
How to fix this CVE
Update your Linux kernel to version 6.19.12 or later to patch the AEAD cipher algorithm vulnerability in the kernel's cryptographic subsystem. This vulnerability affects in-place cryptographic operations and has been resolved by reverting to safer out-of-place processing. Apply the kernel update immediately, as this issue is actively exploited in the wild.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed kernel version with 'uname -r' and compare against 6.19.12 (vulnerable if 6.19.0 through 6.19.11)
- Step 2: Verify AEAD cipher algorithms are in use by checking 'cat /proc/crypto | grep aead' for active cipher modules
- Step 3: Search system logs for cryptographic operation failures with 'grep -i "aead\|crypto" /var/log/kern.log /var/log/messages | grep -i error
- Step 4: Confirm patch applied by verifying kernel version post-update with 'uname -r' shows version 6.19.12 or later
FAQ
What is CVE-2026-31431?
This vulnerability exists in the Linux kernel's AEAD (Authenticated Encryption with Associated Data) cipher implementation, where flawed in-place cryptographic processing could lead to memory corruption and privilege escalation.
Is CVE-2026-31431 being actively exploited?
Yes, CVE-2026-31431 is actively exploited in the wild and is listed on the CISA Known Exploited Vulnerabilities catalog, making immediate patching critical.
What versions of Kernel are affected by CVE-2026-31431?
Kernel versions 6.19.0 through 6.19.11 are vulnerable. Version 6.19.12 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-31431?
Run 'uname -r' and check if the output shows kernel 6.19.0 to 6.19.11. If so, your system is vulnerable and requires immediate kernel update.
Does Defensia detect CVE-2026-31431?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the Linux kernel is installed on a monitored server, CVE-2026-31431 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/19d43105a97be0810edbda875f2cd03f30dc130c
- https://git.kernel.org/stable/c/3115af9644c342b356f3f07a4dd1c8905cd9a6fc
- https://git.kernel.org/stable/c/893d22e0135fa394db81df88697fba6032747667
- https://git.kernel.org/stable/c/8b88d99341f139e23bdeb1027a2a3ae10d341d82
- https://git.kernel.org/stable/c/961cfa271a918ad4ae452420e7c303149002875b
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-31431. Free for 1 server.
Get started free