high CVSS 8 EPSS 1.0%

CVE-2026-29170·Apache vulnerability

A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.68-1~deb12u1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.0% — higher than 63% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.68-1~deb12u1

Fixed in: 2.4.68-1~deb12u1

How to fix this CVE

Apache HTTP Server versions up to 2.4.67 contain a cross-site scripting flaw in the mod_proxy_ftp module when generating HTML directory listings through proxy configurations. Upgrade to Apache 2.4.68 or later to eliminate this vulnerability. Organizations relying on FTP proxying should prioritize this update to prevent potential XSS injection attacks targeting users who access directory listings.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

GET|POST requests to FTP proxy URLs containing directory listings with unencoded HTML tags, script tags, or event handlers in filenames; log pattern: /ftp://.*[<script>|onerror=|onclick=|javascript:].*\.html/

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or encode responses from FTP proxy directory listings that contain unescaped HTML special characters (< > " '). Implement output encoding rules for all proxy responses containing user-controlled directory names before rendering as HTML.

How to check if you are affected

  1. Run 'apache2ctl -v' or 'httpd -v' to retrieve the installed Apache version and confirm if it is 2.4.67 or earlier
  2. Check if mod_proxy_ftp is enabled by running 'apache2ctl -M | grep proxy_ftp' or 'httpd -M | grep proxy_ftp'; if present, the system is potentially vulnerable
  3. Review Apache access and error logs in /var/log/apache2/ or /var/log/httpd/ for requests containing script tags or HTML entities in FTP directory listing URLs (e.g., ftp:// proxy requests with encoded characters)
  4. After updating to 2.4.68, re-run 'apache2ctl -v' or 'httpd -v' to confirm the patched version is active and restart Apache with 'sudo systemctl restart apache2' or 'sudo systemctl restart httpd'

FAQ

What is CVE-2026-29170?

CVE-2026-29170 is an XSS vulnerability in Apache's mod_proxy_ftp module that fails to properly sanitize HTML when rendering FTP directory listings through proxy configurations. Attackers can inject malicious scripts into directory names that execute in browsers of users viewing the listings.

Is CVE-2026-29170 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits have been disclosed.

What versions of Apache are affected by CVE-2026-29170?

Apache HTTP Server versions up to and including 2.4.67 are affected. Version 2.4.68 and later contain the fix.

How do I check if my server is vulnerable to CVE-2026-29170?

Run 'apache2ctl -v' or 'httpd -v' to check your version. If the output shows 2.4.67 or earlier AND 'apache2ctl -M | grep proxy_ftp' or 'httpd -M | grep proxy_ftp' returns a match, your server is vulnerable.

Does Defensia detect CVE-2026-29170?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-29170 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-29170. Free for 1 server.

Get started free