high CVSS 8.8 EPSS 0.65%

CVE-2026-24072·Apache vulnerability

An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.67
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.65% — higher than 50% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-24072 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.65%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.67

Fixed in: 2.4.67

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.67 or later to remediate a privilege escalation vulnerability that allows .htaccess authors to bypass access restrictions and read server files with httpd user privileges. This update patches multiple modules that were improperly validating file access requests from local configuration directives. Organizations should prioritize this update as it affects the security boundary between web content authors and protected system files.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Apache version with: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS/Amazon Linux)
  2. Step 2: Verify all .htaccess files are properly owned by root and not by web users: find /var/www -name '.htaccess' -exec ls -l {} \;
  3. Step 3: Search Apache access and error logs for unauthorized file read attempts from .htaccess context: grep -i 'htaccess\|permission denied' /var/log/apache2/error.log
  4. Step 4: Confirm the patch by checking the installed version matches 2.4.67 or later: apache2ctl -v | grep 'Server version'

FAQ

What is CVE-2026-24072?

CVE-2026-24072 is a privilege escalation vulnerability in Apache HTTP Server where .htaccess file authors can leverage module misconfigurations to access files that would normally require elevated httpd user privileges, bypassing intended access controls.

Is CVE-2026-24072 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though organizations should still prioritize patching due to the high CVSS score.

What versions of Apache are affected by CVE-2026-24072?

Apache HTTP Server versions 2.4.66 and earlier are vulnerable. The vulnerability is fixed in version 2.4.67 and later.

How do I check if my server is vulnerable to CVE-2026-24072?

Run 'apache2ctl -v' or 'httpd -v' to display your Apache version. If the version is 2.4.66 or earlier, your server is vulnerable and requires immediate updating to 2.4.67 or later.

Does Defensia detect CVE-2026-24072?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-24072 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-24072. Free for 1 server.

Get started free