high CVSS 8.8 EPSS 50% Public exploit available

CVE-2026-23918·Apache vulnerability

Double Free and possible RCE vulnerability in Apache HTTP Server with the HTTP/2 protocol. This issue affects Apache HTTP Server: 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Severity
high
Software
Apache
Fixed in
2.4.67-1~deb12u2
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 50% — in the top 1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.67-1~deb12u2

Fixed in: 2.4.67-1~deb12u2

How to fix this CVE

Apache HTTP Server versions up to 2.4.66 contain a critical double-free vulnerability in HTTP/2 stream handling that can lead to remote code execution. Immediately upgrade to version 2.4.67-1~deb12u2 or later to patch this flaw. Prioritize this update for production systems, as public exploits are available and the vulnerability can be triggered by authenticated attackers over the network.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET.*HTTP/2.*:method|:path|:authority.*\x00|\xff.*stream.*reset|ERR_STREAM_CLOSED

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Disable HTTP/2 protocol support at the web application firewall or reverse proxy layer by setting 'h2' off in Apache configuration (e.g., 'Protocols h2off http/1.1') until patched; implement strict request size limits and connection timeouts to reduce exploitation surface.

How to check if you are affected

  1. Run 'apache2ctl -v' or 'httpd -v' to check the installed Apache version; versions 2.4.66 and earlier are vulnerable
  2. Verify HTTP/2 is enabled by checking 'apache2ctl -M | grep http2' (output should show 'http2_module' if active)
  3. Search Apache error and access logs for patterns like 'H2:STREAM' or 'ERR_STREAM_CLOSED' paired with unexpected connection resets
  4. Confirm the patch by re-running 'apache2ctl -v' after upgrade; version should be 2.4.67-1~deb12u2 or higher

FAQ

What is CVE-2026-23918?

CVE-2026-23918 is a critical double-free memory corruption flaw in Apache HTTP Server's HTTP/2 protocol handler that allows authenticated network attackers to trigger a use-after-free condition, potentially achieving remote code execution on the affected server.

Is CVE-2026-23918 being actively exploited?

While not yet on the CISA KEV catalog, public exploits are available (Exploit-DB reference 52577), indicating real-world exploitation risk is present and threat actors have proof-of-concept code.

What versions of Apache are affected by CVE-2026-23918?

Apache HTTP Server version 2.4.66 and all earlier versions are vulnerable; the fix is available in version 2.4.67-1~deb12u2 and later releases.

How do I check if my server is vulnerable to CVE-2026-23918?

Execute 'apache2ctl -v' or 'httpd -v' and compare the version number against 2.4.66; if your version is 2.4.66 or lower and HTTP/2 module is enabled, your server is vulnerable.

Does Defensia detect CVE-2026-23918?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2026-23918 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-23918. Free for 1 server.

Get started free