medium CVSS 4.4 EPSS 0.12%

CVE-2026-107817·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the mysql_json plugin assumed that imported MySQL tables contained valid MySQL binary JSON data. A specially prepared MySQL table containing invalid JSON data could cause out-of-bounds reads, information disclosure, or a server crash. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Severity
medium
Software
MariaDB
Fixed in
13.0.2
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.12% — higher than 2% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 13.0.1

Until: 13.0.2

Fixed in: 13.0.2

How to fix this CVE

Update MariaDB to version 11.8.9 or later to resolve a vulnerability in the mysql_json plugin that fails to validate imported JSON data properly. Unpatched servers running versions 10.6.1 through 13.0.1 are at risk of crashes, information leaks, and memory corruption when processing malformed JSON structures from imported MySQL tables. Apply the security patch immediately and test the upgrade in a non-production environment first.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed MariaDB version: mysql --version or mariadb --version
  2. Query the server version within MariaDB: SELECT VERSION(); from any MySQL client
  3. List all installed plugins to confirm mysql_json is active: SELECT PLUGIN_NAME, PLUGIN_STATUS FROM INFORMATION_SCHEMA.PLUGINS WHERE PLUGIN_NAME LIKE '%json%';
  4. Verify the patch was applied by confirming the version matches or exceeds 11.8.9, 11.4.13, 12.3.3, or 13.0.2 depending on your release series

FAQ

What is CVE-2026-107817?

This vulnerability affects MariaDB's mysql_json plugin, which fails to validate binary JSON data during table imports. Attackers with database access can craft malicious MySQL tables with corrupted JSON to trigger out-of-bounds memory reads, causing server crashes or leaking sensitive information.

Is CVE-2026-107817 being actively exploited?

No, there are currently no public exploits or active exploitation campaigns targeting this vulnerability in the wild.

What versions of MariaDB are affected by CVE-2026-107817?

Affected versions include 10.6.1–10.6.27, 10.11.0–10.11.18, 11.4.0–11.4.12, 11.8.0–11.8.8, 12.3.0–12.3.2, and 13.0.0–13.0.1. Fixed versions are 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2 or later.

How do I check if my server is vulnerable to CVE-2026-107817?

Run SELECT VERSION(); in MariaDB and compare the output to the affected ranges listed above. If your version falls within the vulnerable range, your server needs patching immediately.

Does Defensia detect CVE-2026-107817?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-107817 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-107817. Free for 1 server.

Get started free