CVE-2025-39964·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: crypto: af_alg - Disallow concurrent writes in af_alg_sendmsg Issuing two writes to the same af_alg socket is bogus as the data will be interleaved in an unpredictable fashion. Furthermore, concurrent writes may create inconsistencies in the internal socket state. Disallow this by adding a new ctx->write field that indiciates exclusive ownership for writing.
- Severity
- high
- Software
- Kernel
- Fixed in
- 6.16.9
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.3% — higher than 69% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 6.13
Until: 6.16.9
Fixed in: 6.16.9
How to fix this CVE
Update your Linux kernel to version 6.16.9 or later to patch the af_alg socket write concurrency vulnerability. This fix enforces exclusive write access to af_alg sockets, preventing data interleaving and internal state corruption that could result from simultaneous write operations. Apply the update immediately as this vulnerability is actively exploited in the wild.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Check your current kernel version: uname -r
- Verify if af_alg module is loaded: lsmod | grep af_alg
- Review dmesg logs for af_alg-related errors: dmesg | grep -i af_alg
- After patching, confirm the new kernel version boots: uname -r should show 6.16.9 or later
FAQ
What is CVE-2025-39964?
CVE-2025-39964 is a kernel vulnerability in the AF_ALG socket subsystem that allows concurrent write operations to corrupt the socket's internal state and interleave cryptographic data. The vulnerability stems from missing mutual exclusion controls that should serialize write operations.
Is CVE-2025-39964 being actively exploited?
Yes, CVE-2025-39964 is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, indicating active exploitation in the wild. No public exploit code has been disclosed, but threat actors have demonstrated practical attacks.
What versions of Kernel are affected by CVE-2025-39964?
Linux kernel versions 6.13 through 6.16.8 are vulnerable. Kernel 6.16.9 and later versions contain the fix that adds the ctx->write mutual exclusion field.
How do I check if my server is vulnerable to CVE-2025-39964?
Run 'uname -r' to display your kernel version. If the output shows 6.13.x through 6.16.8, your system is vulnerable. Additionally, check if af_alg is enabled: grep -i af_alg /boot/config-$(uname -r)
Does Defensia detect CVE-2025-39964?
Yes — Defensia's CVE advisory scanner compares installed kernel versions against the NVD database. If a vulnerable kernel version is detected on a monitored server, CVE-2025-39964 will appear in your dashboard with remediation steps and priority alerts.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/0f28c4adbc4a97437874c9b669fd7958a8c6d6ce
- https://git.kernel.org/stable/c/1b34cbbf4f011a121ef7b2d7d6e6920a036d5285
- https://git.kernel.org/stable/c/1f323a48e9b5ebfe6dc7d130fdf5c3c0e92a07c8
- https://git.kernel.org/stable/c/45bcf60fe49b37daab1acee57b27211ad1574042
- https://git.kernel.org/stable/c/7c4491b5644e3a3708f3dbd7591be0a570135b84
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-39964. Free for 1 server.
Get started free