CVE-2025-38352·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: posix-cpu-timers: fix race between handle_posix_cpu_timers() and posix_cpu_timer_del() If an exiting non-autoreaping task has already passed exit_notify() and calls handle_posix_cpu_timers() from IRQ, it can be reaped by its parent or debugger right after unlock_task_sighand(). If a concurrent posix_cpu_timer_del() runs at that moment, it won't be able to detect timer->it.cpu.firing != 0: cpu_timer_task_rcu() and/or lock_task_sighand() will fail. Add the tsk->exit_state check into run_posix_cpu_timers() to fix this. This fix is not needed if CONFIG_POSIX_CPU_TIMERS_TASK_WORK=y, because exit_task_work() is called before exit_notify(). But the check still makes sense, task_work_add(&tsk->posix_cputimers_work.work) will fail anyway in this case.
- Severity
- high
- Software
- Kernel
- Fixed in
- 6.15.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.3% — higher than 69% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 6.13
Until: 6.15.3
Fixed in: 6.15.3
How to fix this CVE
Update your Linux kernel to version 6.15.3 or later to resolve a critical race condition in POSIX CPU timer handling. This vulnerability allows privilege escalation when a non-autoreaping task exits while handling timers concurrently with timer deletion operations. Apply the kernel update immediately and reboot your system to fully mitigate the risk.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Check installed kernel version: uname -r — ensure version is 6.15.3 or later
- Verify POSIX CPU timers are active: grep CONFIG_POSIX_CPU_TIMERS /boot/config-$(uname -r) | grep -q '^CONFIG_POSIX_CPU_TIMERS=y' && echo 'POSIX timers enabled'
- Search kernel logs for timer-related errors: dmesg | grep -i 'posix.*timer\|cpu.*timer' — look for segfaults or locking failures
- Confirm patch application: git log --oneline /path/to/kernel/source | grep -i '2c72fe18\|2f3daa04\|460188bc' to verify the fix commit is present
FAQ
What is CVE-2025-38352?
CVE-2025-38352 is a race condition in the Linux kernel's POSIX CPU timer subsystem that occurs when a process exits while timer handlers and timer deletion operations execute concurrently, potentially leading to privilege escalation and system compromise.
Is CVE-2025-38352 being actively exploited?
Yes, CVE-2025-38352 is actively exploited in the wild and is listed in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit proof-of-concept has been disclosed, but active exploitation campaigns have been observed.
What versions of Kernel are affected by CVE-2025-38352?
Kernel versions 6.13 through 6.15.2 are vulnerable. Version 6.15.3 and later contain the fix. Systems running LTS kernels (5.15, 6.1, 6.6) are not affected unless they backport vulnerable timer code.
How do I check if my server is vulnerable to CVE-2025-38352?
Run `uname -r` to display your kernel version. If the output shows 6.13.x, 6.14.x, or 6.15.0-6.15.2, your system is vulnerable and requires immediate patching.
Does Defensia detect CVE-2025-38352?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2025-38352 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/2c72fe18cc5f9f1750f5bc148cf1c94c29e106ff
- https://git.kernel.org/stable/c/2f3daa04a9328220de46f0d5c919a6c0073a9f0b
- https://git.kernel.org/stable/c/460188bc042a3f40f72d34b9f7fc6ee66b0b757b
- https://git.kernel.org/stable/c/764a7a5dfda23f69919441f2eac2a83e7db6e5bb
- https://git.kernel.org/stable/c/78a4b8e3795b31dae58762bc091bb0f4f74a2200
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-38352. Free for 1 server.
Get started free