CVE-2025-32023·Redis vulnerability
Redis is an open source, in-memory database that persists on disk. From 2.8 to before 8.0.3, 7.4.5, 7.2.10, and 6.2.19, an authenticated user may use a specially crafted string to trigger a stack/heap out of bounds write on hyperloglog operations, potentially leading to remote code execution. The bug likely affects all Redis versions with hyperloglog operations implemented. This vulnerability is fixed in 8.0.3, 7.4.5, 7.2.10, and 6.2.19. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing hyperloglog operations. This can be done using ACL to restrict HLL commands.
- Severity
- high
- Software
- Redis
- Fixed in
- 8.0.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 6.5% — in the top 6% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.0.0
Until: 8.0.3
Fixed in: 8.0.3
How to fix this CVE
Update Redis immediately to version 8.0.3 or later to patch a memory corruption vulnerability in hyperloglog operations that could allow authenticated attackers to execute arbitrary code. If immediate patching is not feasible, restrict hyperloglog command execution (PFADD, PFCOUNT, PFMERGE) using Redis ACL rules to prevent exploitation until the upgrade is completed.
sudo dnf update redisDefensia detects this vulnerability
How to check if you are affected
- Run `redis-cli INFO server | grep redis_version` to check the installed Redis version and confirm if it is below 8.0.3, 7.4.5, 7.2.10, or 6.2.19 (depending on your branch)
- Check Redis ACL permissions by running `redis-cli ACL LIST` to verify if unauthorized users have access to hyperloglog commands (PFADD, PFCOUNT, PFMERGE)
- Search Redis server logs (typically in /var/log/redis/) for patterns like 'hyperloglog', 'PFADD', 'PFCOUNT', or 'PFMERGE' commands executed by non-administrative users, especially with unusual or malformed string arguments
- After patching, verify the fix with `redis-cli INFO server | grep redis_version` to confirm the version matches the fixed release
FAQ
What is CVE-2025-32023?
CVE-2025-32023 is a memory corruption vulnerability in Redis hyperloglog operations that permits authenticated users to write beyond allocated memory boundaries, potentially enabling remote code execution through specially crafted string inputs.
Is CVE-2025-32023 being actively exploited?
While not currently listed on the CISA KEV catalog, public exploit code is available (Exploit-DB ID 52477), making this vulnerability a practical threat to unpatched instances with weak access controls.
What versions of Redis are affected by CVE-2025-32023?
Redis versions from 2.8 through 8.0.2, 7.4.4, 7.2.9, and 6.2.18 are vulnerable. Version 8.0.3 and later branch releases (7.4.5, 7.2.10, 6.2.19) include the fix.
How do I check if my server is vulnerable to CVE-2025-32023?
Connect to Redis and run `INFO server` to retrieve the version number. If it is older than 8.0.3, 7.4.5, 7.2.10, or 6.2.19 (depending on your branch), your installation is vulnerable.
Does Defensia detect CVE-2025-32023?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Redis is installed on a monitored server, CVE-2025-32023 will appear in your dashboard with remediation steps.
Related Redis CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-32023. Free for 1 server.
Get started free