CVE-2022-49094·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: net/tls: fix slab-out-of-bounds bug in decrypt_internal The memory size of tls_ctx->rx.iv for AES128-CCM is 12 setting in tls_set_sw_offload(). The return value of crypto_aead_ivsize() for "ccm(aes)" is 16. So memcpy() require 16 bytes from 12 bytes memory space will trigger slab-out-of-bounds bug as following: ================================================================== BUG: KASAN: slab-out-of-bounds in decrypt_internal+0x385/0xc40 [tls] Read of size 16 at addr ffff888114e84e60 by task tls/10911 Call Trace: <TASK> dump_stack_lvl+0x34/0x44 print_report.cold+0x5e/0x5db ? decrypt_internal+0x385/0xc40 [tls] kasan_report+0xab/0x120 ? decrypt_internal+0x385/0xc40 [tls] kasan_check_range+0xf9/0x1e0 memcpy+0x20/0x60 decrypt_internal+0x385/0xc40 [tls] ? tls_get_rec+0x2e0/0x2e0 [tls] ? process_rx_list+0x1a5/0x420 [tls] ? tls_setup_from_iter.constprop.0+0x2e0/0x2e0 [tls] decrypt_skb_update+0x9d/0x400 [tls] tls_sw_recvmsg+0x3c8/0xb50 [tls] Allocated by task 10911: kasan_save_stack+0x1e/0x40 __kasan_kmalloc+0x81/0xa0 tls_set_sw_offload+0x2eb/0xa20 [tls] tls_setsockopt+0x68c/0x700 [tls] __sys_setsockopt+0xfe/0x1b0 Replace the crypto_aead_ivsize() with prot->iv_size + prot->salt_size when memcpy() iv value in TLS_1_3_VERSION scenario.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 5.17.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 16% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2022-49094 scores 9.8 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 5.17
Until: 5.17.3
Fixed in: 5.17.3
How to fix this CVE
Update your Linux kernel to version 5.17.3 or later to patch a memory buffer overflow in the TLS decryption path that affects AES-CCM cipher configurations. This vulnerability can cause kernel crashes and potential privilege escalation on systems using TLS 1.3 with specific cipher suites. Reboot the system after kernel patching to ensure the fix is active.
sudo dnf update kernel kernel-devel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Run 'uname -r' to check the currently running kernel version; if it is 5.17.0 through 5.17.2, your system is vulnerable
- Verify TLS offloading is enabled by checking 'cat /proc/sys/net/tls/device' (returns 1 if enabled) and confirm active TLS connections with 'ss -tan | grep :443'
- Search dmesg logs for KASAN warnings: 'dmesg | grep -i "slab-out-of-bounds\|decrypt_internal"' to identify exploitation attempts
- After patching, confirm the new kernel is loaded with 'uname -r' and verify no slab allocation errors appear in 'journalctl -u kernel --since "1 hour ago" | grep -i kasan'
FAQ
What is CVE-2022-49094?
This vulnerability is a buffer overflow in the Linux kernel's TLS decryption routine that occurs when using AES-CCM ciphers in TLS 1.3. The IV buffer is allocated with insufficient size (12 bytes) but the crypto function expects 16 bytes, causing a slab-out-of-bounds read that crashes the kernel or may allow privilege escalation.
Is CVE-2022-49094 being actively exploited?
No, this vulnerability is not listed in the CISA KEV catalog and has no known public exploits. However, it can be triggered reliably by any local user configuring TLS with vulnerable cipher settings, making it a denial-of-service risk.
What versions of Kernel are affected by CVE-2022-49094?
Linux kernel versions 5.17.0 through 5.17.2 are vulnerable. Version 5.17.3 and later contain the fix.
How do I check if my server is vulnerable to CVE-2022-49094?
Run 'uname -r' and check if the output is 5.17.0, 5.17.1, or 5.17.2; if so, your system is vulnerable and requires immediate kernel update.
Does Defensia detect CVE-2022-49094?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2022-49094 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/2304660ab6c425df64d95301b601424c6a50f28b
- https://git.kernel.org/stable/c/29be1816cbab9a0dc6243120939fd10a92753756
- https://git.kernel.org/stable/c/2b7d14c105dd8f6412eda5a91e1e6154653731e3
- https://git.kernel.org/stable/c/589154d0f18945f41d138a5b4e49e518d294474b
- https://git.kernel.org/stable/c/6e2f1b033b17dedda51d465861b69e58317d6343
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2022-49094. Free for 1 server.
Get started free