high CVSS 7.5 Actively exploited EPSS 65% Public exploit available

CVE-2019-0211·Apache vulnerability

In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.

Severity
high
Software
Apache
Fixed in
2.4.38-3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 65% — in the top 0.7% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.38-3

Fixed in: 2.4.38-3

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.38-3 or later immediately. This vulnerability allows unprivileged child processes to escalate privileges and run arbitrary code as root by exploiting the scoreboard mechanism. Update through your distribution's package manager or compile from source if necessary.

sudo dnf update httpd -y && sudo systemctl restart httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'apache2 -v' (Ubuntu/Debian) or 'httpd -v' (RHEL/CentOS) to display the installed Apache version and compare against 2.4.38-3
  2. Check which MPM module is active by running 'apache2ctl -M' and confirming if event, worker, or prefork is loaded
  3. Search Apache error and access logs for unexpected privilege escalations or child process anomalies: grep -i 'scoreboard\|segmentation\|permission denied' /var/log/apache2/error.log
  4. Verify the patched version is running by restarting Apache and re-running the version command to confirm 2.4.38-3 or higher

FAQ

What is CVE-2019-0211?

CVE-2019-0211 is a privilege escalation vulnerability in Apache HTTP Server that allows child processes running with reduced privileges to manipulate the shared scoreboard memory segment and inject arbitrary code executed with root privileges. This affects only Unix-based systems running Apache 2.4.17 through 2.4.38 with event, worker, or prefork MPM modules.

Is CVE-2019-0211 being actively exploited?

Yes. CVE-2019-0211 is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and public exploits are available, making active exploitation a serious threat. Organizations running vulnerable versions should prioritize patching immediately.

What versions of Apache are affected by CVE-2019-0211?

Apache HTTP Server versions 2.4.17 through 2.4.38 (inclusive) are affected on Unix/Linux systems. The vulnerability is fixed in version 2.4.38-3 and all later releases.

How do I check if my server is vulnerable to CVE-2019-0211?

Run 'apache2 -v' or 'httpd -v' and check if the version falls between 2.4.17 and 2.4.38. Then verify an affected MPM is active with 'apache2ctl -M | grep mpm' (should show event, worker, or prefork). If both conditions are true, your server is vulnerable.

Does Defensia detect CVE-2019-0211?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2019-0211 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2019-0211. Free for 1 server.

Get started free