critical CVSS 9 EPSS 95% Public exploit available

CVE-2017-9798·Apache vulnerability

Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.

Severity
critical
Software
Apache
Fixed in
2.4.27-6
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 95% — in the top 0.1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.27-6

Fixed in: 2.4.27-6

How to fix this CVE

Upgrade Apache httpd to version 2.4.27-6 or later to patch the Optionsbleed vulnerability that allows unauthorized memory disclosure. This memory leak occurs when the OPTIONS HTTP method is mishandled in conjunction with the Limit directive, potentially exposing sensitive data from the web server process. Ensure your .htaccess file restrictions and httpd.conf directives are properly configured after patching.

sudo dnf update httpd -y && sudo systemctl restart httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

^(GET|POST|PUT|DELETE|HEAD|TRACE|CONNECT) / HTTP/1\.[01]$ | OPTIONS [^ ]+ HTTP/1\.[01]$ with Content-Length or Transfer-Encoding headers present

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or restrict unauthenticated OPTIONS requests at the WAF level by adding a rule to deny OPTIONS method requests unless from trusted IPs. Additionally, enforce authentication for any requests targeting .htaccess-protected directories and monitor for repeated OPTIONS probe attempts from the same source IP.

How to check if you are affected

  1. Run 'apache2ctl -v' or 'httpd -v' to check your current Apache version and verify if it is earlier than 2.4.27-6
  2. Check if .htaccess files contain Limit directives by running 'grep -r "<Limit" /var/www' to identify potential attack surface
  3. Search Apache access logs for OPTIONS requests with unusual patterns: 'grep -E "OPTIONS.*HTTP" /var/log/apache2/access.log | head -20'
  4. Verify the patch by confirming the installed version shows 2.4.27-6 or higher after running 'apache2ctl -v' post-update

Indicators of compromise

  • OPTIONS request to root path (/) without authentication headers
  • Rapid sequence of OPTIONS requests targeting different URI paths
  • OPTIONS requests with abnormal headers designed to trigger memory reads
  • ExploitDB POC usage patterns (slow memory leak probing)

FAQ

What is CVE-2017-9798?

CVE-2017-9798, also known as Optionsbleed, is a use-after-free vulnerability in Apache httpd that leaks sensitive process memory when the OPTIONS HTTP method is processed with improperly configured Limit directives. An unauthenticated attacker can trigger memory disclosure by sending crafted OPTIONS requests.

Is CVE-2017-9798 being actively exploited?

While CVE-2017-9798 is not listed in the CISA KEV catalog as actively exploited in the wild, public exploits are available on ExploitDB, making it a known-risk vulnerability that should be patched promptly.

What versions of Apache are affected by CVE-2017-9798?

Apache httpd versions 2.2.x through 2.2.34 and 2.4.x through 2.4.27 are affected. The fix was released in version 2.4.27-6 and later.

How do I check if my server is vulnerable to CVE-2017-9798?

Run 'apache2ctl -v' or 'httpd -v' to display the version. If the version is 2.4.27 or earlier, your server is vulnerable. Additionally, check for Limit directives in .htaccess files with 'grep -r "<Limit" /var/www'.

Does Defensia detect CVE-2017-9798?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2017-9798 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2017-9798. Free for 1 server.

Get started free