critical CVSS 9 EPSS 49% Public exploit available

CVE-2016-0736·Apache vulnerability

In Apache HTTP Server versions 2.4.0 to 2.4.23, mod_session_crypto was encrypting its data/cookie using the configured ciphers with possibly either CBC or ECB modes of operation (AES256-CBC by default), hence no selectable or builtin authenticated encryption. This made it vulnerable to padding oracle attacks, particularly with CBC.

Severity
critical
Software
Apache
Fixed in
2.4.25-1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 49% — in the top 1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.25-1

Fixed in: 2.4.25-1

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.25-1 or later to address a cryptographic weakness in mod_session_crypto that allows padding oracle attacks against encrypted session cookies. The vulnerability stems from the use of unauthenticated encryption modes (CBC/ECB) without integrity protection, which attackers can exploit to decrypt sensitive session data. Immediately apply the patch to all production Apache servers, especially those using mod_session_crypto for session management.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'apache2 -v' or 'httpd -v' to check the installed Apache version; versions 2.4.0 through 2.4.23 are vulnerable
  2. Run 'apache2ctl -M | grep session_crypto' or 'httpctl -M | grep session_crypto' to confirm mod_session_crypto is loaded
  3. Check Apache configuration files in /etc/apache2/mods-enabled/ or /etc/httpd/conf.modules.d/ for 'session_crypto' directives
  4. Run 'apache2 -v' again after patching to confirm the version is 2.4.25-1 or higher and restart Apache with 'sudo systemctl restart apache2' or 'sudo systemctl restart httpd'

FAQ

What is CVE-2016-0736?

CVE-2016-0736 is a cryptographic vulnerability in Apache mod_session_crypto that uses unauthenticated encryption (CBC/ECB mode) for session cookies, allowing attackers to perform padding oracle attacks to decrypt session data without knowing the encryption key.

Is CVE-2016-0736 being actively exploited?

CVE-2016-0736 is not listed in CISA's Known Exploited Vulnerabilities catalog, but public proof-of-concept exploits are available, making it a realistic threat if mod_session_crypto is deployed.

What versions of Apache are affected by CVE-2016-0736?

Apache HTTP Server versions 2.4.0 through 2.4.23 are vulnerable; version 2.4.25-1 and later contain the fix.

How do I check if my server is vulnerable to CVE-2016-0736?

Run 'apache2 -v' (or 'httpd -v' on RHEL/CentOS) and verify the version is below 2.4.25; then confirm mod_session_crypto is enabled with 'apache2ctl -M | grep session_crypto' or 'httpctl -M | grep session_crypto'.

Does Defensia detect CVE-2016-0736?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2016-0736 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2016-0736. Free for 1 server.

Get started free