CVE-2026-98365·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: RDMA/rxe: Fix integer overflow in mr_check_range() leading to OOB access mr_check_range() validates that [iova, iova+length) falls within the registered MR range using wraparound-prone arithmetic: if (iova < mr->ibmr.iova || iova + length > mr->ibmr.iova + mr->ibmr.length) A remote peer can craft an RDMA-Write/Read RETH so that iova + length wraps to 0 (e.g. iova=0xfffffffffffffff8, length=8), bypassing the check. rxe_mr_iova_to_index() then computes a huge index (int idx, only guarded by WARN_ON) and rxe_mr_copy_xarray() dereferences mr->page_info[huge], causing an out-of-bounds read/write and a kernel oops that is triggerable by an unauthenticated remote peer. Rewrite the check in overflow-safe form; the first two clauses guarantee that the subsequent subtractions do not underflow: if (iova < mr->ibmr.iova || length > mr->ibmr.length || iova - mr->ibmr.iova > mr->ibmr.length - length) With the fix, mr_check_range() returns -EINVAL for the crafted iova and the responder reports REMOTE_ACCESS_ERROR instead of triggering the OOB.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 6.6.158, 6.12.112, 6.18.54, 7.2.8, 7.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.38% — higher than 32% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-98365 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.38%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
How to fix this CVE
Update your Linux kernel to a patched stable release to fix an integer overflow vulnerability in the RDMA/rxe subsystem that allows remote attackers to trigger out-of-bounds memory access. Identify your current kernel branch (6.6, 6.12, 6.18, or 7.2) and update to the corresponding fixed version: 6.6.158, 6.12.112, 6.18.54, or 7.2.8 respectively. Contact your distribution vendor for backported security updates if you cannot upgrade kernel branches immediately.
sudo dnf check-update kernel && sudo dnf install kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Check installed kernel version: uname -r
- Verify if RDMA/rxe subsystem is loaded: lsmod | grep rdma or lsmod | grep rxe
- Review kernel logs for WARN_ON messages or out-of-bounds access indicators: dmesg | grep -i 'rdma\|rxe\|oob'
- Confirm kernel patch level: cat /proc/version and compare against fixed versions 6.6.158+, 6.12.112+, 6.18.54+, or 7.2.8+
FAQ
What is CVE-2026-98365?
This vulnerability is an integer overflow in the Linux kernel's RDMA/rxe (Reliable Datagram Memory Access over Converged Ethernet) subsystem that allows remote unauthenticated peers to bypass memory range validation and trigger out-of-bounds memory access, potentially causing kernel crashes or data corruption.
Is CVE-2026-98365 being actively exploited?
No—this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are available, though the remote triggering nature and lack of authentication requirements suggest exploitation is feasible.
What versions of Kernel are affected by CVE-2026-98365?
All kernel versions prior to the fixed releases are potentially affected; the fix is available in stable branches 6.6.158, 6.12.112, 6.18.54, 7.2.8, and mainline 7.3 onwards.
How do I check if my server is vulnerable to CVE-2026-98365?
Run 'uname -r' and compare the kernel version against fixed versions. If your kernel is older than 6.6.158, 6.12.112, 6.18.54, or 7.2.8 (depending on your branch), and RDMA/rxe is enabled, your system is vulnerable.
Does Defensia detect CVE-2026-98365?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the kernel package is installed on a monitored server, CVE-2026-98365 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/2f3b705144e3a3c14184fec6e354680081fe91ec
- https://git.kernel.org/stable/c/3431f525718f6b07da308cda6d44f8cb548bbd37
- https://git.kernel.org/stable/c/5d9426a74fc8cb8f375fcdc19b465a030f9b8cab
- https://git.kernel.org/stable/c/b7d2118660545a00b21e83010ded1a231c6fb8c5
- https://git.kernel.org/stable/c/d10e2a08799e858d3e71ea4169bcd018f216d444
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-98365. Free for 1 server.
Get started free