CVE-2026-98323·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: RDMA/siw: Bound fragmented header copies by the remaining length siw_get_hdr() can receive an extended DDP/RDMAP header across more than one TCP callback. The first callback may receive most of the header, while the next one still limits the copy to hdrlen - MIN_DDP_HDR instead of the number of missing bytes. This makes the destination move past the end of the header and overwrite the receive state, including fpdu_part_rcvd. A later callback can then use a negative fpdu_part_rcvd value as a copy offset, which creates an OOB write. Use the number of header bytes already received when calculating the next copy length.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 5.10.271, 5.15.222, 6.1.189, 6.6.158, 6.12.112, 6.18.54, 7.2.8, 7.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.51% — higher than 44% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-98323 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.51%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
How to fix this CVE
Update your Linux kernel to a patched stable release immediately. If you are running kernel 5.10, 5.15, 6.1, 6.6, 6.12, 6.18, or 7.2, upgrade to versions 5.10.271, 5.15.222, 6.1.189, 6.6.158, 6.12.112, 6.18.54, or 7.2.8 respectively—do not jump to mainline. Alternatively, install your Linux distribution's kernel security update package, which will backport the fix to your current kernel branch.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Run `uname -r` to display your current kernel version and compare it against the fixed versions (5.10.271+, 5.15.222+, 6.1.189+, 6.6.158+, 6.12.112+, 6.18.54+, or 7.2.8+)
- Confirm the RDMA/siw (Soft iWARP) transport driver is loaded by running `lsmod | grep siw`; if not present, the system is not vulnerable
- Search kernel logs for memory corruption indicators: `sudo dmesg | grep -i 'out of bounds\|oob\|memory\|siw' | tail -20`
- After applying patches, reboot the system and re-run `uname -r` to confirm the new kernel version matches a fixed release
FAQ
What is CVE-2026-98323?
This vulnerability exists in the Linux kernel's RDMA/siw (Soft iWARP) driver, where fragmented DDP/RDMAP header processing can overwrite kernel receive state when header data arrives across multiple TCP callbacks. An attacker with network access can trigger an out-of-bounds write using a negative copy offset, leading to kernel memory corruption.
Is CVE-2026-98323 being actively exploited?
No, this vulnerability is not listed on CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is currently available. However, the critical CVSS 9.8 score warrants urgent patching.
What versions of Kernel are affected by CVE-2026-98323?
The vulnerability affects multiple stable kernel branches: 5.10 (before 5.10.271), 5.15 (before 5.15.222), 6.1 (before 6.1.189), 6.6 (before 6.6.158), 6.12 (before 6.12.112), 6.18 (before 6.18.54), and 7.2 (before 7.2.8), plus mainline versions before 7.3.
How do I check if my server is vulnerable to CVE-2026-98323?
Run `uname -r` to check your kernel version, then verify it is at least 5.10.271, 5.15.222, 6.1.189, 6.6.158, 6.12.112, 6.18.54, 7.2.8, or 7.3 depending on your branch. Also check `lsmod | grep siw` to confirm whether RDMA/siw is in use.
Does Defensia detect CVE-2026-98323?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the Linux kernel is installed on a monitored server, CVE-2026-98323 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/262dcd809723723ed8a4e05437ec7e9c21a8f17e
- https://git.kernel.org/stable/c/2c6fbcf4bfac0b2b186acc8d91154c0fa24468a7
- https://git.kernel.org/stable/c/8628f8ebf41669302513fb3f0bf0eba38b226742
- https://git.kernel.org/stable/c/9ff797e516dbc1ecb73701ec4c24055712d44411
- https://git.kernel.org/stable/c/af9f5b474a260ad23ffb9793d716a5e3bbce3b48
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-98323. Free for 1 server.
Get started free