CVE-2026-60002·OpenSSH vulnerability
ssh in OpenSSH before 10.4 can have a use-after-free when a server changes its host key during a key re-exchange. (This outcome occurs only on the client side.)
- Severity
- high
- Software
- OpenSSH
- Fixed in
- 10.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.30% — higher than 21% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-60002 scores 7.7 on CVSS, so a successful attack would be serious — but at 0.30%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 10.4
Fixed in: 10.4
How to fix this CVE
OpenSSH clients before version 10.4p1-1 are vulnerable to a use-after-free memory corruption issue that occurs during host key re-exchange operations. This vulnerability can lead to client-side crashes or potential code execution when connecting to servers that rotate their host keys. Immediately update OpenSSH to version 10.4p1-1 or later to eliminate this memory safety defect.
sudo dnf update openssh-server openssh-clients openssh -yDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check OpenSSH version with `ssh -V` and `sshd -v` to identify if the installed version is older than 10.4p1-1
- Step 2: Verify client-side SSH functionality by attempting key re-exchange with `ssh -v -o RekeyLimit=1M user@host` to observe if crashes occur during re-keying
- Step 3: Review system logs with `journalctl -u ssh -n 100` or `tail -f /var/log/auth.log` for segmentation faults or memory-related SSH errors during active sessions
- Step 4: Confirm the patch was applied by running `ssh -V` again and verifying the version reports 1:10.4p1-1 or higher
FAQ
What is CVE-2026-60002?
CVE-2026-60002 is a use-after-free vulnerability in OpenSSH clients that occurs when a remote server changes its host key during a key re-exchange negotiation, potentially allowing memory corruption on the client side.
Is CVE-2026-60002 being actively exploited?
No, according to CISA's Known Exploited Vulnerabilities catalog, CVE-2026-60002 is not currently being exploited in the wild, and no public exploit code is available.
What versions of OpenSSH are affected by CVE-2026-60002?
All OpenSSH versions prior to 10.4p1-1 are vulnerable to this issue on the client side only. This includes all 10.3 and earlier releases.
How do I check if my server is vulnerable to CVE-2026-60002?
Run `ssh -V` to display the installed client version and `sshd -v` for the server version. If the version is earlier than 10.4p1-1, the system is vulnerable.
Does Defensia detect CVE-2026-60002?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-60002 will appear in your dashboard with remediation steps.
Related OpenSSH CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60002. Free for 1 server.
Get started free