high CVSS 8.5 EPSS 89% Public exploit available

CVE-2016-6210·OpenSSH vulnerability

sshd in OpenSSH before 7.3, when SHA256 or SHA512 are used for user password hashing, uses BLOWFISH hashing on a static password when the username does not exist, which allows remote attackers to enumerate users by leveraging the timing difference between responses when a large password is provided.

Severity
high
Software
OpenSSH
Fixed in
1:7.2p2-6
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 89% — in the top 0.2% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 1:7.2p2-6

Fixed in: 1:7.2p2-6

How to fix this CVE

Upgrade OpenSSH to version 7.3 or later to eliminate a timing-based user enumeration vulnerability in the authentication process. This flaw allows attackers to discover valid usernames by measuring response delays when SHA256/SHA512 password hashing is configured. Patch your SSH server immediately and restart the sshd service to apply the fix.

sudo dnf update openssh-server openssh-clients && sudo systemctl restart sshd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

Regex pattern for sshd logs: ^.*Invalid user [a-zA-Z0-9_]+.* with multiple rapid attempts from same source IP where password length varies significantly (e.g., 128+ character attempts followed by short attempts)

How to check if you are affected

  1. Check installed OpenSSH version: ssh -V or sshd -v
  2. Verify sshd configuration hash algorithm: grep -i 'passwordauthentication\|usepam' /etc/ssh/sshd_config
  3. Search auth logs for repeated failed login attempts from single IP with varying password lengths: grep 'Invalid user' /var/log/auth.log | awk '{print $10}' | sort | uniq -c | sort -rn
  4. Confirm patch applied: dpkg -l openssh-server (Debian/Ubuntu) or rpm -qa openssh-server (RHEL/CentOS) and verify version is 7.3 or higher

FAQ

What is CVE-2016-6210?

This vulnerability allows remote attackers to enumerate valid usernames on OpenSSH servers by measuring the response time difference between authentication attempts for existing vs. non-existing users. When SHA256 or SHA512 hashing is enabled, the server applies different computational loads that leak information about user existence.

Is CVE-2016-6210 being actively exploited?

While not currently listed on CISA's Known Exploited Vulnerabilities catalog, public proof-of-concept exploits are available and the attack requires only network access to SSH, making it a practical reconnaissance tool for attackers.

What versions of OpenSSH are affected by CVE-2016-6210?

All OpenSSH versions before 7.3 are vulnerable when configured to use SHA256 or SHA512 password hashing algorithms. This includes all 7.2 and earlier releases.

How do I check if my server is vulnerable to CVE-2016-6210?

Run 'ssh -V' to check your version (vulnerable if below 7.3), then verify your sshd configuration uses SHA256/SHA512: grep -i 'passwordauthentication' /etc/ssh/sshd_config. If both conditions are true, your server is exploitable.

Does Defensia detect CVE-2016-6210?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2016-6210 will appear in your dashboard with remediation steps.

Related OpenSSH CVEs

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2016-6210. Free for 1 server.

Get started free