CVE-2026-60000·OpenSSH vulnerability
sshd in OpenSSH before 10.4 allows remote attackers to cause a denial of service (resource consumption from excessive authentication attempts) because MaxAuthTries was mishandled for GSSAPIAuthentication.
- Severity
- low
- Software
- OpenSSH
- Fixed in
- 10.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.62% — higher than 48% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
Until: 10.4
Fixed in: 10.4
How to fix this CVE
Update OpenSSH to version 1:10.4p1-1 or later to remediate a denial-of-service vulnerability in GSSAPI authentication handling. The vulnerability allows remote attackers to exhaust server resources by triggering excessive authentication retry logic without proper rate limiting on GSSAPI attempts. Prioritize this update for systems exposing SSH to untrusted networks.
sudo dnf update openssh-server -y && sudo systemctl restart sshdDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
Failed GSSAPI authentication attempts in rapid succession within short time windows; regex pattern: 'Failed GSSAPI|GSSAPI authentication (failed|error)' appearing more than MaxAuthTries threshold in /var/log/auth.log within 60-second intervalsHow to check if you are affected
- Check installed OpenSSH version: ssh -V or sshd -v to confirm if running a version before 10.4p1
- Verify GSSAPI authentication is enabled in sshd config: grep -i gssapiauthentication /etc/ssh/sshd_config (if present and set to 'yes', the system is at risk)
- Search SSH logs for repeated GSSAPI authentication failures: grep -c 'GSSAPI' /var/log/auth.log or journalctl -u ssh | grep -i gssapi to identify potential exploitation attempts
- Confirm patch applied: ssh -V should report version 10.4p1 or higher, and verify with dpkg -l | grep openssh-server (Debian/Ubuntu) or rpm -qa | grep openssh-server (RHEL/CentOS)
FAQ
What is CVE-2026-60000?
CVE-2026-60000 is a denial-of-service vulnerability in OpenSSH's GSSAPI authentication handler where the MaxAuthTries limit is not properly enforced, allowing attackers to trigger resource exhaustion through repeated authentication attempts.
Is CVE-2026-60000 being actively exploited?
No, CVE-2026-60000 is not currently listed in the CISA Known Exploited Vulnerabilities catalog and no public exploit code is available.
What versions of OpenSSH are affected by CVE-2026-60000?
All versions prior to 1:10.4p1-1 are affected; this includes OpenSSH 10.3 and earlier releases across all major Linux distributions.
How do I check if my server is vulnerable to CVE-2026-60000?
Run 'ssh -V' to display your version and compare against 10.4p1; if your version is lower, you are vulnerable. Additionally, check if GSSAPI is enabled with 'grep GSSAPIAuthentication /etc/ssh/sshd_config'.
Does Defensia detect CVE-2026-60000?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-60000 will appear in your dashboard with remediation steps.
Related OpenSSH CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60000. Free for 1 server.
Get started free