medium CVSS 5.9 EPSS 0.16%

CVE-2026-59999·OpenSSH vulnerability

In sshd in OpenSSH before 10.4, DisableForwarding=yes was supposed to take precedence over PermitTunnel=yes, but did not.

Severity
medium
Software
OpenSSH
Fixed in
10.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.16% — higher than 4% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 10.4

Fixed in: 10.4

How to fix this CVE

Update OpenSSH to version 10.4 or later to ensure that the DisableForwarding directive properly overrides tunnel permissions. This fixes a configuration precedence issue where tunnel forwarding could remain enabled even when explicitly disabled at the server level. Prioritize this update for systems where tunnel access must be restricted for security compliance.

sudo dnf update openssh-server openssh-clients

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed OpenSSH version: ssh -V
  2. Verify your sshd configuration contains DisableForwarding=yes: sudo grep -i 'DisableForwarding\|PermitTunnel' /etc/ssh/sshd_config
  3. Review sshd logs for tunnel-related connection attempts: sudo grep -i 'tun\|forward' /var/log/auth.log or /var/log/secure
  4. Confirm the fix by verifying OpenSSH version is 10.4p1 or later: ssh -V | grep -E '10\.[4-9]|[1-9][0-9]\.' && echo 'Patched' || echo 'Vulnerable'

FAQ

What is CVE-2026-59999?

This vulnerability is a configuration logic error in OpenSSH sshd where the DisableForwarding security setting failed to block tunnel access when PermitTunnel was also configured, allowing administrators' intended access restrictions to be bypassed.

Is CVE-2026-59999 being actively exploited?

No, this vulnerability is not listed in CISA's Known Exploited Vulnerabilities catalog, and no public exploits are currently available.

What versions of OpenSSH are affected by CVE-2026-59999?

All versions of OpenSSH prior to 10.4 are affected by this configuration precedence issue.

How do I check if my server is vulnerable to CVE-2026-59999?

Run 'ssh -V' and compare the version number to 10.4; if your version is lower and your sshd_config contains both PermitTunnel and DisableForwarding directives, your configuration may not enforce the intended restrictions.

Does Defensia detect CVE-2026-59999?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-59999 will appear in your dashboard with remediation steps.

Related OpenSSH CVEs

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-59999. Free for 1 server.

Get started free