CVE-2026-59997·OpenSSH vulnerability
internal-sftp in sshd in OpenSSH before 10.4 recognizes only the first 9 command-line arguments, which can be important if a later command-line argument would have helped to ensure the intended security properties of an SFTP connection.
- Severity
- medium
- Software
- OpenSSH
- Fixed in
- 10.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.18% — higher than 6% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
Until: 10.4
Fixed in: 10.4
How to fix this CVE
Update OpenSSH to version 10.4p1-1 or later to resolve an argument parsing limitation in the internal-sftp subsystem. This vulnerability could allow attackers to bypass intended security configurations by exploiting how command-line arguments are processed during SFTP session initialization. Apply the security update immediately across all SSH-enabled servers.
sudo dnf update openssh-server openssh-clientsDefensia detects this vulnerability
How to check if you are affected
- Run 'ssh -V' or 'sshd -V' to check the installed OpenSSH version; affected versions are below 10.4p1-1
- Check if the SFTP subsystem is enabled in /etc/ssh/sshd_config by searching for 'Subsystem sftp' configuration entries
- Review SSH logs for SFTP session initialization attempts, typically found in /var/log/auth.log (Debian/Ubuntu) or /var/log/secure (RHEL/CentOS/Amazon Linux)
- After patching, restart the SSH daemon with 'sudo systemctl restart sshd' and verify the new version with 'sshd -V' to confirm the fix is active
FAQ
What is CVE-2026-59997?
CVE-2026-59997 is a vulnerability in OpenSSH's internal-sftp subsystem where only the first 9 command-line arguments are recognized during processing. This limitation can prevent later arguments that enforce important security restrictions from taking effect, potentially weakening SFTP connection security.
Is CVE-2026-59997 being actively exploited?
No, CVE-2026-59997 is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and there are no publicly available exploits. However, it should still be patched promptly as a best practice for SSH security hardening.
What versions of OpenSSH are affected by CVE-2026-59997?
OpenSSH versions prior to 10.4p1-1 are affected. This includes all versions up to and including 10.3p1 and earlier.
How do I check if my server is vulnerable to CVE-2026-59997?
Run 'sshd -V' to display your installed version. If the output shows a version lower than 10.4p1-1, your server requires patching.
Does Defensia detect CVE-2026-59997?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-59997 will appear in your dashboard with remediation steps.
Related OpenSSH CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-59997. Free for 1 server.
Get started free