medium CVSS 4.2 EPSS 0.25%

CVE-2026-59995·OpenSSH vulnerability

sftp in OpenSSH before 10.4 does not properly constrain the location of downloaded files when "sftp server:/path ." is used with an attacker-controlled server.

Severity
medium
Software
OpenSSH
Fixed in
10.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.25% — higher than 15% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 10.4

Fixed in: 10.4

How to fix this CVE

Update OpenSSH to version 1:10.4p1-1 or later to remediate a directory traversal vulnerability in the SFTP client. This vulnerability allows an attacker operating a malicious SFTP server to place downloaded files outside the intended destination directory. Administrators should prioritize this update for systems that use SFTP to transfer files from untrusted or external servers.

sudo dnf update openssh-server openssh-clients

Defensia detects this vulnerability

How to check if you are affected

  1. Check the installed OpenSSH version by running: ssh -V
  2. Verify if SFTP client functionality is in use by checking for sftp connections in process list: ps aux | grep sftp
  3. Review SSH audit logs for suspicious SFTP download activities: grep -i sftp /var/log/auth.log | grep -i download
  4. Confirm the patch is applied by verifying the version matches or exceeds 1:10.4p1-1: dpkg -l | grep openssh-server (Debian/Ubuntu) or rpm -qa | grep openssh-server (RHEL/CentOS)

FAQ

What is CVE-2026-59995?

CVE-2026-59995 is a directory traversal vulnerability in OpenSSH's SFTP client that permits an attacker running a rogue SFTP server to write downloaded files to arbitrary locations on the client system instead of the specified target directory.

Is CVE-2026-59995 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, the vulnerability requires user interaction to be triggered.

What versions of OpenSSH are affected by CVE-2026-59995?

All OpenSSH versions prior to 10.4p1-1 are affected. The vulnerability has been patched starting with version 1:10.4p1-1.

How do I check if my server is vulnerable to CVE-2026-59995?

Run ssh -V and compare the output to version 10.4p1-1. If your version is lower, your system is vulnerable. You can also use: dpkg -l openssh-server (Debian/Ubuntu) or rpm -qa openssh-server (RHEL/CentOS).

Does Defensia detect CVE-2026-59995?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-59995 will appear in your dashboard with remediation steps.

Related OpenSSH CVEs

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-59995. Free for 1 server.

Get started free