CVE-2026-43185·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix signededness bug in smb_direct_prepare_negotiation() smb_direct_prepare_negotiation() casts an unsigned __u32 value from sp->max_recv_size and req->preferred_send_size to a signed int before computing min_t(int, ...). A maliciously provided preferred_send_size of 0x80000000 will return as smaller than max_recv_size, and then be used to set the maximum allowed alowed receive size for the next message. By sending a second message with a large value (>1420 bytes) the attacker can then achieve a heap buffer overflow. This fix replaces min_t(int, ...) with min_t(u32)
- Severity
- critical
- Software
- Kernel
- Fixed in
- 6.19.6
- Published
Affected versions
From: 6.19
Until: 6.19.6
Fixed in: 6.19.6
How to fix this CVE
Update your Linux kernel to version 6.19.6 or later to patch a critical signededness bug in the SMB Direct protocol handler. This vulnerability allows remote attackers to trigger heap buffer overflows through crafted SMB negotiation messages. Immediately apply kernel updates and reboot your systems to eliminate exposure to this network-reachable flaw.
sudo dnf update kernel && sudo rebootDefensia detects this vulnerability
How to check if you are affected
- Check installed kernel version: uname -r | grep -E '^6\.19\.[0-5]' && echo 'VULNERABLE' || echo 'PATCHED or different kernel'
- Verify SMB Direct (port 445) is accessible: ss -tlnp | grep ':445' to confirm ksmbd service is running and exposed
- Search kernel logs for heap corruption warnings: journalctl -u kernel --since='24 hours ago' | grep -i 'heap\|buffer\|overflow\|ksmbd'
- Confirm kernel upgrade applied: uname -r should show 6.19.6 or higher; verify with apt-cache policy linux-image-generic or dnf info kernel
FAQ
What is CVE-2026-43185?
A critical integer signedness bug in the Linux kernel's SMB Direct protocol negotiation handler that allows attackers to cause heap buffer overflows by sending specially crafted SMB negotiation packets with malicious size parameters.
Is CVE-2026-43185 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, given the critical CVSS score of 9.8 and network accessibility, proactive patching is essential.
What versions of Kernel are affected by CVE-2026-43185?
Linux kernel versions 6.19 through 6.19.5 are affected. The fix was released in kernel 6.19.6. If you are running kernel 6.19.0, 6.19.1, 6.19.2, 6.19.3, 6.19.4, or 6.19.5, your system is vulnerable.
How do I check if my server is vulnerable to CVE-2026-43185?
Run `uname -r` and check if the output matches 6.19.0 through 6.19.5. If it does, you are vulnerable. Also verify ksmbd is active with `systemctl status ksmbd` or `ps aux | grep ksmbd`.
Does Defensia detect CVE-2026-43185?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-43185 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/1c268fd2f59dc9ccb2c2a7d1f439b232dbe1c06c
- https://git.kernel.org/stable/c/55abc475d096da4a5356b6efb0cfdc6156bc1550
- https://git.kernel.org/stable/c/56eab82fa6fb5ca024b0514e249d40d9b23ee5a7
- https://git.kernel.org/stable/c/6b4f875aac344cdd52a1f34cc70ed2f874a65757
- https://git.kernel.org/stable/c/a110dbe928561d440e9e117d17331139a0bedace
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-43185. Free for 1 server.
Get started free