critical CVSS 9.9 EPSS <0.1%

CVE-2026-39355·PHP vulnerability

Genealogy is a family tree PHP application. Prior to 5.9.1, a critical broken access control vulnerability in the genealogy application allows any authenticated user to transfer ownership of arbitrary non-personal teams to themselves. This enables complete takeover of other users’ team workspaces and unrestricted access to all genealogy data associated with the compromised team. This vulnerability is fixed in 5.9.1.

Severity
critical
Software
PHP
Fixed in
5.9.1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 17% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-39355 scores 9.9 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 5.9.1

Fixed in: 5.9.1

How to fix this CVE

Upgrade the Genealogy PHP application to version 5.9.1 or later to patch a critical authorization bypass that allows authenticated users to assume control of team workspaces. This vulnerability permits unauthorized access to sensitive genealogy data and requires immediate patching in production environments. After upgrading, verify that team ownership transfers are restricted to authorized administrators only.

sudo dnf update php

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check PHP version installed: php -v and verify the Genealogy application version with grep -r 'version' /path/to/genealogy/config or check the application's admin panel
  2. Step 2: Query the database to identify team ownership records: SELECT user_id, team_id, owner_id FROM teams; to spot mismatched or suspicious ownership changes
  3. Step 3: Search application logs for unauthorized team transfer operations: grep -i 'transfer\|ownership\|team.*change' /path/to/genealogy/logs/ for timestamps outside normal maintenance windows
  4. Step 4: After patching, verify fix by attempting to transfer a test team with a non-owner authenticated account—the operation should be rejected with a permission denied error

FAQ

What is CVE-2026-39355?

This is a broken access control flaw in Genealogy PHP applications prior to 5.9.1 that allows any authenticated user to hijack ownership of team workspaces belonging to other users, granting them full access to all associated genealogy records and data.

Is CVE-2026-39355 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though organizations should still prioritize patching due to its critical severity and ease of exploitation by insider threats.

What versions of PHP are affected by CVE-2026-39355?

All versions of the Genealogy PHP application prior to version 5.9.1 are vulnerable; the exact earliest affected version is unknown but likely spans multiple releases.

How do I check if my server is vulnerable to CVE-2026-39355?

Run php -v to check PHP version and verify your Genealogy application version by checking the application's configuration files or admin interface; if it is below 5.9.1, your system is vulnerable.

Does Defensia detect CVE-2026-39355?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PHP is installed on a monitored server, CVE-2026-39355 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.
CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2025-62521CVSS 10ChurchCRM is an open-source church management system. Prior to version 5.21.0, a pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The vulnerability exists in `setup/routes/setup.php` where user input from the setup form is directly concatenated into a PHP configuration template without any validation or sanitization. Any parameter in the setup form can be used to inject PHP code that gets written to `Include/Config.php`, which is then executed on every page load. This is more severe than typical authenticated RCE vulnerabilities because it requires no credentials and affects the installation process that administrators must complete. Version 5.21.0 patches the issue.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-39355. Free for 1 server.

Get started free