critical CVSS 9.9 EPSS 0.81%

CVE-2026-25510·PHP vulnerability

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.28.5.0, an authenticated user with file editor permissions can achieve Remote Code Execution (RCE) by leveraging the file creation and save endpoints, an attacker can upload and execute arbitrary PHP code on the server. This issue has been patched in version 0.28.5.0.

Severity
critical
Software
PHP
Fixed in
0.28.5.0
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.81% — higher than 53% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-25510 scores 9.9 on CVSS, so a successful attack would be serious — but at 0.81%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 0.28.5.0

Fixed in: 0.28.5.0

How to fix this CVE

Update CI4MS to version 0.28.5.0 or later to patch a critical remote code execution vulnerability in the file editor functionality. This vulnerability allows authenticated users with file editing permissions to upload and execute arbitrary PHP code on your server. Apply the update immediately as this is a critical severity issue (CVSS 9.9).

sudo dnf update php

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST /file/save|POST /file/create with Content-Type: application/x-www-form-urlencoded or multipart/form-data containing PHP code patterns (<?php|eval|system|exec|shell_exec|passthru) in file content or filename parameters

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or rate-limit POST requests to CI4MS file editor endpoints (/file/save, /file/create) unless originating from trusted administrative IP ranges. Implement request body inspection to reject uploads containing PHP execution functions (eval, system, exec, passthru, base64_decode followed by eval). Require additional authentication headers or tokens for file operations.

How to check if you are affected

  1. Run `php -v` to check your current PHP version and verify the CI4MS installation path in your web root
  2. Check the CI4MS version by examining `composer.json` or the version file in your CI4MS installation directory (usually located in `/var/www/html/` or similar)
  3. Search web server logs for POST requests to `/file/save` or `/file/create` endpoints with suspicious payloads: `grep -E '(file/(save|create)|\.(php|phtml|php3|php4|php5))' /var/log/apache2/access.log`
  4. Verify the patch by checking the commit hash in your git history or comparing your installed CI4MS version number against 0.28.5.0 using `composer show ci4-cms-erp/ci4ms`

FAQ

What is CVE-2026-25510?

CVE-2026-25510 is a critical remote code execution vulnerability in CI4MS (CodeIgniter 4 CMS) that allows authenticated users with file editor permissions to upload and execute arbitrary PHP code by exploiting the file creation and save functionality.

Is CVE-2026-25510 being actively exploited?

No, according to CISA KEV data, CVE-2026-25510 is not currently listed as actively exploited in the wild. However, no public exploit is publicly available, which does not guarantee safety—you should still patch immediately due to the critical severity rating.

What versions of CI4MS are affected by CVE-2026-25510?

All versions of CI4MS prior to and including version 0.28.4.x are vulnerable. The vulnerability was patched in version 0.28.5.0 and later.

How do I check if my server is vulnerable to CVE-2026-25510?

Run `composer show ci4-cms-erp/ci4ms` in your CI4MS installation directory to check the installed version. If it is below 0.28.5.0, your server is vulnerable. Additionally, verify that file editor permissions are assigned to any user accounts by checking the RBAC configuration in your CI4MS admin panel.

Does Defensia detect CVE-2026-25510?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If CI4MS or PHP is installed on a monitored server, CVE-2026-25510 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2024-5932CVSS 10The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.14.1 via deserialization of untrusted input from the 'give_title' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely, and to delete arbitrary files.
CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.
CVE-2025-46348CVSS 10YesWiki is a wiki system written in PHP. Prior to version 4.5.4, the request to commence a site backup can be performed and downloaded without authentication. The archives are created with a predictable filename, so a malicious user could create and download an archive without being authenticated. This could result in a malicious attacker making numerous requests to create archives and fill up the file system, or by downloading the archive which contains sensitive site information. This issue has been patched in version 4.5.4.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-25510. Free for 1 server.

Get started free