CVE-2026-19385·PostgreSQL vulnerability
Heap buffer overflow in PostgreSQL pg_dump of long function transform lists allows an object creator to execute arbitrary code as the operating system user running pg_dump, via a crafted transform list. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
- Severity
- high
- Software
- PostgreSQL
- Fixed in
- 18.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.43% — higher than 35% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-19385 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.43%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 18.0
Until: 18.5
Fixed in: 18.5
How to fix this CVE
Upgrade PostgreSQL to version 18.6 or later to patch a critical heap buffer overflow in pg_dump that could allow arbitrary code execution. Organizations running versions 14.x through 18.5 should prioritize this update immediately. The vulnerability is triggered when pg_dump processes specially crafted transform lists, so all database administrators using this utility should ensure their instances are updated.
sudo dnf update postgresql-server postgresql-contribDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed PostgreSQL version with: psql --version or sudo -u postgres psql -c 'SELECT version();'
- Step 2: Verify pg_dump is present and determine if it's used in automated backup scripts: which pg_dump && grep -r 'pg_dump' /etc/cron* /var/spool/cron
- Step 3: Search PostgreSQL logs for errors related to transform lists or pg_dump crashes: grep -i 'transform\|pg_dump' /var/log/postgresql/*.log | grep -i 'error\|fatal\|buffer\|overflow'
- Step 4: After patching, confirm the version has been updated: psql --version and verify PostgreSQL service restarted: sudo systemctl restart postgresql
FAQ
What is CVE-2026-19385?
This vulnerability is a heap buffer overflow in PostgreSQL's pg_dump utility that occurs when processing overly long function transform lists. An attacker with object creation privileges can craft a malicious transform list to trigger memory corruption and execute arbitrary code with the privileges of the operating system user running pg_dump.
Is CVE-2026-19385 being actively exploited?
No, according to CISA's Known Exploited Vulnerabilities catalog, CVE-2026-19385 is not currently being exploited in the wild. However, no public exploit code exists yet, so prompt patching remains essential as proof-of-concept may emerge.
What versions of PostgreSQL are affected by CVE-2026-19385?
PostgreSQL versions 14.0 through 18.5 are vulnerable. This includes all patch releases of 14, 15, 16, 17, and the initial 18.x releases up to 18.5. Users on PostgreSQL 13 and earlier are unaffected.
How do I check if my server is vulnerable to CVE-2026-19385?
Run 'psql --version' or 'sudo -u postgres psql -c "SELECT version();"' and compare against the affected ranges: 14.x, 15.x, 16.x, 17.x, or 18.0-18.5. If your version falls within these ranges, your server is vulnerable.
Does Defensia detect CVE-2026-19385?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-19385 will appear in your dashboard with remediation steps and automated patch deployment options.
Related PostgreSQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-19385. Free for 1 server.
Get started free