high CVSS 8.8 EPSS 0.42%

CVE-2026-14677·PostgreSQL vulnerability

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Severity
high
Software
PostgreSQL
Fixed in
18.5
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.42% — higher than 35% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-14677 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.42%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 18.0

Until: 18.5

Fixed in: 18.5

How to fix this CVE

Upgrade PostgreSQL to version 18.6 or later to remediate an integer wraparound vulnerability affecting 32-bit builds of pltcl and plperl extensions. This flaw allows database object creators to trigger undersized memory allocations leading to out-of-bounds writes and potential arbitrary code execution. Organizations running PostgreSQL 18.0–18.5 should prioritize this update to prevent privilege escalation within the database context.

sudo dnf upgrade postgresql-server postgresql-contrib

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed PostgreSQL version with: psql --version or sudo -u postgres psql -c 'SELECT version();'
  2. Step 2: Verify if pltcl or plperl extensions are installed by querying: SELECT * FROM pg_available_extensions WHERE name IN ('pltcl', 'plperl');
  3. Step 3: Review PostgreSQL server logs for unusual memory allocation errors or segmentation faults around user-defined function creation: sudo tail -100 /var/log/postgresql/postgresql.log | grep -i 'wraparound\|allocation\|segfault'
  4. Step 4: After patching, confirm the version with psql --version and verify no extension re-initialization was needed: sudo -u postgres psql -c 'SELECT extname, extversion FROM pg_extension WHERE extname IN ("pltcl", "plperl");'

FAQ

What is CVE-2026-14677?

This vulnerability is an integer wraparound bug in PostgreSQL's pltcl and plperl extension code on 32-bit systems that permits database object owners to craft malicious function bodies, causing the server to allocate insufficient memory and write beyond buffer boundaries, potentially enabling arbitrary code execution with database server privileges.

Is CVE-2026-14677 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits have been released, but the high CVSS score of 8.8 and the requirement for only low-privilege database user access make it a significant risk.

What versions of PostgreSQL are affected by CVE-2026-14677?

PostgreSQL versions 18.0 through 18.5, as well as earlier branch versions (17.0–17.10, 16.0–16.14, 15.0–15.18, and 14.0–14.23) are affected; upgrade to 18.6, 17.11, 16.15, 15.19, or 14.24 respectively to remediate.

How do I check if my server is vulnerable to CVE-2026-14677?

Run 'psql --version' and check if your version falls within the vulnerable range (18.0–18.5 for the latest branch); additionally, confirm your PostgreSQL build is 32-bit via 'sudo -u postgres psql -c "SELECT version();"' and inspect for 'x86' or 'i686' in the output.

Does Defensia detect CVE-2026-14677?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-14677 will appear in your dashboard with remediation steps.

Related PostgreSQL CVEs

CVE-2026-14671CVSS 8.8Type confusion in PostgreSQL module "refint" allows an object creator to execute arbitrary code as the operating system user running the database. The fix for this emerged as a non-security bug report, and the fix appear in the git repository with subject "refint: Remove plan cache.", without a CVE number. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14680CVSS 8.8Type confusion with PostgreSQL "internal" data type arguments allows any user to execute arbitrary code as the operating system user running the database, via calls to functions with that argument type. Type "internal" represents a class of mutually-incompatible data structures not intended for access from SQL. The system intended to prevent such function calls, but this prevention had gaps. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14676CVSS 8.8Heap buffer overflow in PostgreSQL pg_stat_statements allows the query author to execute arbitrary code as the operating system user running the database, via crafted queries containing array constants. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.
CVE-2026-15741CVSS 8.8SQL injection in PostgreSQL EXTRACT() deparse allows an object owner to execute arbitrary SQL as a superuser via a hostile object definition. Attacks affect expression deparse consumers broadly, including pg_dump, psql commands like \sf, and any similar usage in non-core tools. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14670CVSS 8.8Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-14677. Free for 1 server.

Get started free