CVE-2026-14681·PostgreSQL vulnerability
Improper enforcement of message integrity in PostgreSQL GSSAPI support allows a user to negotiate GSSAPI contrary to pg_hba.conf rules, via initial direct TLS connection. Despite a pg_hba.conf that appears to require GSSAPI, the connection may exchange data over TLS encryption alone. If the TLS settings are more permissive than the GSS settings, the connection may continue with lesser protection. Within major versions 17-18, minor versions before PostgreSQL 18.6 and 17.11 are affected. Versions before PostgreSQL 17 are unaffected.
- Severity
- medium
- Software
- PostgreSQL
- Fixed in
- 18.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — in the bottom 1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 18.0
Until: 18.5
Fixed in: 18.5
How to fix this CVE
PostgreSQL versions 18.0 through 18.5 contain a flaw in GSSAPI message integrity enforcement that allows clients to bypass authentication requirements specified in pg_hba.conf by establishing TLS-only connections when GSSAPI should be mandatory. Upgrade to PostgreSQL 18.6 or later to restore proper authentication policy enforcement and prevent unauthorized connection downgrades.
sudo dnf update postgresql-server postgresql-contribDefensia detects this vulnerability
How to check if you are affected
- Check installed PostgreSQL version: SELECT version();
- Verify GSSAPI configuration in pg_hba.conf: grep -n 'gss' /etc/postgresql/*/main/pg_hba.conf
- Review PostgreSQL logs for TLS-only connections when GSSAPI is required: grep -i 'gss\|SSL' /var/log/postgresql/postgresql.log | tail -100
- Confirm the fix: sudo -u postgres psql -c "SELECT version();" and verify version is 18.6 or higher
FAQ
What is CVE-2026-14681?
This vulnerability allows PostgreSQL clients to circumvent GSSAPI authentication policies by negotiating TLS-only encryption instead, effectively bypassing mandatory strong authentication rules configured in pg_hba.conf.
Is CVE-2026-14681 being actively exploited?
No, there are no known active exploits or public proof-of-concepts for this vulnerability at this time.
What versions of PostgreSQL are affected by CVE-2026-14681?
PostgreSQL versions 18.0 through 18.5 are affected. Versions 17 and earlier are not vulnerable. PostgreSQL 18.6 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-14681?
Run sudo -u postgres psql -c "SELECT version();" and check if the version is between 18.0 and 18.5 and if your pg_hba.conf contains GSSAPI authentication requirements.
Does Defensia detect CVE-2026-14681?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-14681 will appear in your dashboard with remediation steps.
Related PostgreSQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-14681. Free for 1 server.
Get started free