medium CVSS 4.2 EPSS 0.29%

CVE-2026-106552·OpenSSH vulnerability

In sftp in OpenSSH before 10.6, a server can trigger directory traversal (causing files to be written to unintended locations) during a recursive copy operation.

Severity
medium
Software
OpenSSH
Fixed in
10.6
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.29% — higher than 20% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 10.6

Fixed in: 10.6

How to fix this CVE

Update OpenSSH to version 10.6 or later to resolve a directory traversal vulnerability in the SFTP recursive copy functionality. This flaw could allow an attacker to write files outside the intended directory during file transfer operations. Apply the update immediately to all systems running OpenSSH versions prior to 10.6.

sudo dnf update openssh-server openssh-clients

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed OpenSSH version: ssh -V or sshd -v
  2. Verify SFTP service is enabled: systemctl status ssh (Ubuntu/Debian) or systemctl status sshd (RHEL/CentOS/Amazon Linux)
  3. Search auth logs for suspicious SFTP recursive copy operations: grep -i 'sftp.*copy\|directory traversal' /var/log/auth.log /var/log/secure
  4. Confirm update applied: Compare output of 'ssh -V' against OpenSSH 10.6 release notes at openssh.org/releasenotes.html#10.6

FAQ

What is CVE-2026-106552?

This vulnerability allows an SFTP server to trigger directory traversal during recursive copy operations, potentially causing files to be written to unintended filesystem locations outside the target directory.

Is CVE-2026-106552 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities catalog and has no publicly available exploits.

What versions of OpenSSH are affected by CVE-2026-106552?

All versions of OpenSSH prior to version 10.6 are affected. Systems running OpenSSH 10.6 and later are not vulnerable.

How do I check if my server is vulnerable to CVE-2026-106552?

Run 'ssh -V' and check the version number. If it displays a version lower than 10.6, your system is vulnerable and requires an immediate update.

Does Defensia detect CVE-2026-106552?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2026-106552 will appear in your dashboard with remediation steps.

Related OpenSSH CVEs

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-106552. Free for 1 server.

Get started free